RKE2 allows privilege escalation in Windows nodes due to Insecure Access Control Lists
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/rke2 1.30.2, 1.29.6, 1.28.11, 1.27.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.27.0, < 1.27.15>= 1.28.0, < 1.28.11>= 1.29.0, < 1.29.6>= 1.30.0, < 1.30.2
- Fixed in
- 1.30.2, 1.28.11, 1.29.6, 1.27.15
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x7xj-jvwp-97rv lists affected ranges: Go github.com/rancher/rke2 >=1.27.0 =1.28.0 =1.29.0 =1.30.0 <1.30.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability has been identified whereby RKE2 deployments in Windows nodes have weak Access Control Lists (ACL), allowing BUILTIN\Users or NT AUTHORITY\Authenticated Users to view or edit sensitive files which could lead to privilege escalation. The affected files include binaries, scripts, configuration and log files: This vulnerability is exclusive to RKE2 in Windows environments. Linux environments are not affected by it. Please consult the associated MITRE ATT&CK - Technique - Exploitation for Privilege Escalation for further information about this category of attack. Patches Patched versions include RKE2 1.31.0, 1.30.2, 1.29.6, 1.28.11 and 1.27.15. Workarounds Users are advised to do a fresh install of their RKE2 Windows nodes using a patched RKE2 version. When that is not possible, users can enforce stricter ACLs for all sensitive files affected by this Security Advisory running this PowerShell script as an Administrator on each node. References - CVE-2023-32197 -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x7xj-jvwp-97rv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-x7xj-jvwp-97rv Advisory: RKE2 allows privilege escalation in Windows nodes due to Insecure Access Control Lists IDs: GHSA-x7xj-jvwp-97rv Record: https://patchnext.com/advisories/ghsa-x7xj-jvwp-97rv (revision 1, source checked 26 Oct 2026, 15:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/rke2 1.30.2, 1.29.6, 1.28.11, 1.27.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rancher/rke2: affected >= 1.27.0, < 1.27.15; >= 1.28.0, < 1.28.11; >= 1.29.0, < 1.29.6; >= 1.30.0, < 1.30.2; fixed in 1.30.2, 1.28.11, 1.29.6, 1.27.15 ## Suggested inspection (read-only) - Go github.com/rancher/rke2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rancher/rke2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x7xj-jvwp-97rv (GitHub-reviewed advisory GHSA-x7xj-jvwp-97rv lists affected ranges: Go github.com/rancher/rke2 >=1.27.0 =1.28.0 =1.29.0 =1.30.0 <1.30.2) Commands are suggestions: review each one before running it.
Loading voting…