Skip to content

← Actionable
Low, CVSS 2.3amended

unhead: Streaming SSR streamKey injected into inline script without identifier validation

GHSA-x7mm-9vvv-64w8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (unhead 3.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm unhead

    Affected
    >= 3.0.0-beta.5, <= 3.0.0
    Fixed in
    3.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary createStreamableHead({ streamKey }) interpolated its streamKey argument directly into the streaming SSR bootstrap and suspense-chunk inline scripts without identifier validation or escaping. If an application forwards untrusted data into that configuration value, the rendered scripts become a script-injection sink. Details streamKey was embedded into JavaScript source via dot notation in two public helpers: createBootstrapScript() returned <scriptwindow.${streamKey}={...}</script renderSSRHeadSuspenseChunk() returned window.${streamKey}.push(...) No escaping, quoting, or identifier validation was applied before these strings were embedded into HTML. A streamKey such as unhead;globalThis.PWNED=1;// broke out of the intended property access and injected arbitrary JavaScript into the page. The JSON escaping used for streamed head entries did not protect streamKey because streamKey was inserted as raw code rather than as serialized data. Impact streamKey is a developer-chosen…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x7mm-9vvv-64w8

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-x7mm-9vvv-64w8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-x7mm-9vvv-64w8

Advisory: unhead: Streaming SSR `streamKey` injected into inline script without identifier validation
IDs: GHSA-x7mm-9vvv-64w8
Record: https://patchnext.com/advisories/ghsa-x7mm-9vvv-64w8 (revision 3, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: unhead 3.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm unhead: affected >= 3.0.0-beta.5, <= 3.0.0; fixed in 3.0.1

## Suggested inspection (read-only)
- `npm ls unhead --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on unhead.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x7mm-9vvv-64w8 (OSV record GHSA-x7mm-9vvv-64w8 lists affected ranges: npm unhead >=3.0.0-beta.5 <3.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-x7mm-9vvv-64w8 (GitHub-reviewed advisory GHSA-x7mm-9vvv-64w8 lists affected ranges: npm unhead >=3.0.0-beta.5 <=3.0.0)

Commands are suggestions: review each one before running it.

Loading voting…