Skip to content

← Actionable
Medium, CVSS 6.5

Silverstripe Missing security check on dev/build/defaults

GHSA-x5w2-wcr8-9q45

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/framework 3.3.0, 3.2.2, 3.1.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist silverstripe/framework

    Affected
    >= 3.2.0, <= 3.2.1>= 3.3.0-beta1, < 3.3.0<= 3.1.16
    Fixed in
    3.3.0, 3.2.2, 3.1.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

The buildDefaults method on DevelopmentAdmin is missing a permission check. In live mode, if you access /dev/build, you are requested to login first. However, if you access /dev/build/defaults, then the action is performed without any login check. This should be protected in the same way that /dev/build is. The buildDefaults view is requireDefaultRecords() on each DataObject class, and hence has the potential to modify database state. It also lists all modified tables, allowing attackers more insight into which modules are used, and how the database tables are structured.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x5w2-wcr8-9q45

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-x5w2-wcr8-9q45

Advisory: Silverstripe Missing security check on dev/build/defaults
IDs: GHSA-x5w2-wcr8-9q45
Record: https://patchnext.com/advisories/ghsa-x5w2-wcr8-9q45 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/framework 3.3.0, 3.2.2, 3.1.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/framework: affected >= 3.2.0, <= 3.2.1; >= 3.3.0-beta1, < 3.3.0; <= 3.1.16; fixed in 3.3.0, 3.2.2, 3.1.17

## Suggested inspection (read-only)
- Packagist silverstripe/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x5w2-wcr8-9q45 (GitHub-reviewed advisory GHSA-x5w2-wcr8-9q45 lists affected ranges: Packagist silverstripe/framework >=3.2.0 =3.3.0-beta1 =0 <=3.1.16)

Commands are suggestions: review each one before running it.

Loading voting…