Skip to content

← Actionable
High, CVSS 8.2amended

devalue: stringifyAsync can cause an unhandled rejection despite a caught returned promise

GHSA-x5rw-q4pp-hg5g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (devalue 5.9.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm devalue

    Affected
    >= 5.8.0, <= 5.9.2
    Fixed in
    5.9.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

When serializing multiple promises, a later promise can reject before an earlier one settles. An internal rejected promise remains unhandled even if the caller catches the returned stringifyAsync promise. Under Node's default unhandled-rejection behavior this can terminate the process. Applications whose asynchronous failures/timing can be influenced by requests are potentially exposed. This is essentially impossible to exploit, and is much more likely to surface as a developer-introduced bug.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-x5rw-q4pp-hg5g

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-x5rw-q4pp-hg5g

  4. Revision 1 · created ·

    Published from ghsa record GHSA-x5rw-q4pp-hg5g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-x5rw-q4pp-hg5g

Advisory: devalue: stringifyAsync can cause an unhandled rejection despite a caught returned promise
IDs: GHSA-x5rw-q4pp-hg5g
Record: https://patchnext.com/advisories/ghsa-x5rw-q4pp-hg5g (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: devalue 5.9.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm devalue: affected >= 5.8.0, <= 5.9.2; fixed in 5.9.3

## Suggested inspection (read-only)
- `npm ls devalue --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on devalue.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x5rw-q4pp-hg5g (GitHub-reviewed advisory GHSA-x5rw-q4pp-hg5g lists affected ranges: npm devalue >=5.8.0 <=5.9.2)
- Verified: https://osv.dev/vulnerability/GHSA-x5rw-q4pp-hg5g (OSV record GHSA-x5rw-q4pp-hg5g lists affected ranges: npm devalue >=5.8.0 <5.9.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…