Skip to content

← Actionable
Critical, CVSS 9.1

Transparent TLS may not be applied to Marbles with certain manifest configurations

GHSA-x5r5-2qrx-rqj8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/edgelesssys/marblerun 1.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Transparent TLS (TTLS) is a MarbleRun feature that wraps plain TCP connections between Marbles in TLS. In the manifest, a user defines the connections that should be considered. Impact If a Marble is configured for TTLS, but doesn't have an environment variable defined in its parameters, TTLS is not applied. The traffic will not be encrypted. MarbleRun deployments that don't use TTLS (which is only available with EGo Marbles) are not affected. Patches The issue has been patched in v1.4.1. Workarounds Make sure that all Marbles that use TTLS have an environment variable defined in their parameters. References For a description of TTLS, see <https://docs.edgeless.systems/marblerun/features/transparent-TLS See the updated section on TTLS configuration in the manifest: <https://docs.edgeless.systems/marblerun/workflows/define-manifest#tls

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x5r5-2qrx-rqj8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-x5r5-2qrx-rqj8

Advisory: Transparent TLS may not be applied to Marbles with certain manifest configurations
IDs: GHSA-x5r5-2qrx-rqj8
Record: https://patchnext.com/advisories/ghsa-x5r5-2qrx-rqj8 (revision 1, source checked 26 Oct 2026, 15:03 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/edgelesssys/marblerun 1.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/edgelesssys/marblerun: affected < 1.4.1; fixed in 1.4.1

## Suggested inspection (read-only)
- Go github.com/edgelesssys/marblerun: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/edgelesssys/marblerun.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x5r5-2qrx-rqj8 (GitHub-reviewed advisory GHSA-x5r5-2qrx-rqj8 lists affected ranges: Go github.com/edgelesssys/marblerun >=0 <1.4.1)

Commands are suggestions: review each one before running it.

Loading voting…