Skip to content

← Actionable
Low, CVSS 2.2

OpenSearch has ineffective TLS certificate hostname verification

GHSA-x5hg-x4gv-j98m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opensearch.plugin:opensearch-security 3.3.0.0, 2.19.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.2 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Description A regression was introduced in OpenSearch 2.18.0 that caused the plugins.security.ssl.transport.enforcehostnameverification setting to be ineffective. When this setting was enabled, OpenSearch did not verify that the hostname in a connecting node's TLS certificate matched the hostname of the connection. This could allow a node with a valid certificate (signed by the cluster's trusted CA) but an incorrect hostname SAN to join the cluster. Impact Clusters running affected versions with hostname verification enabled did not receive the expected protection from this setting. A node presenting a certificate signed by the cluster's trusted CA could join the cluster regardless of whether its hostname SAN matched. This regression does not affect certificate validation itself — only the additional hostname verification check. Patches This issue is fixed in OpenSearch 2.19.4 and 3.3.0. Workarounds Use more restrictive values for plugins.security.nodesdn to limit which certificates…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x5hg-x4gv-j98m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-x5hg-x4gv-j98m

Advisory: OpenSearch has ineffective TLS certificate hostname verification
IDs: GHSA-x5hg-x4gv-j98m
Record: https://patchnext.com/advisories/ghsa-x5hg-x4gv-j98m (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.opensearch.plugin:opensearch-security 3.3.0.0, 2.19.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.opensearch.plugin:opensearch-security: affected >= 2.18.0, < 2.19.4.0; >= 3.0.0, < 3.3.0.0; fixed in 2.19.4.0, 3.3.0.0

## Suggested inspection (read-only)
- Maven org.opensearch.plugin:opensearch-security: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.opensearch.plugin:opensearch-security.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x5hg-x4gv-j98m (GitHub-reviewed advisory GHSA-x5hg-x4gv-j98m lists affected ranges: Maven org.opensearch.plugin:opensearch-security >=2.18.0 =3.0.0 <3.3.0.0)

Commands are suggestions: review each one before running it.

Loading voting…