Skip to content

← Actionable
Medium, CVSS 4.3amended

phin may include sensitive headers in subsequent requests after redirect

GHSA-x565-32qp-m3vf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phin 3.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm phin

    Affected
    < 3.7.1
    Fixed in
    3.7.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Users may be impacted if sending requests including sensitive data in specific headers with followRedirects enabled. Patches The follow-redirects library is now being used for redirects and removes some headers that may contain sensitive information in some situations. Workarounds N/A. Please update to resolve the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x565-32qp-m3vf

  2. Revision 1 · created ·

    Published from osv record GHSA-x565-32qp-m3vf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-x565-32qp-m3vf

Advisory: phin may include sensitive headers in subsequent requests after redirect
IDs: GHSA-x565-32qp-m3vf
Record: https://patchnext.com/advisories/ghsa-x565-32qp-m3vf (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phin 3.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm phin: affected < 3.7.1; fixed in 3.7.1

## Suggested inspection (read-only)
- `npm ls phin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x565-32qp-m3vf (OSV record GHSA-x565-32qp-m3vf lists affected ranges: npm phin >=0 <3.7.1 (fixed))
- Verified: https://github.com/advisories/GHSA-x565-32qp-m3vf (GitHub-reviewed advisory GHSA-x565-32qp-m3vf lists affected ranges: npm phin >=0 <3.7.1)

Commands are suggestions: review each one before running it.

Loading voting…