Skip to content

← Actionable
Unratedamended

Ibis PyArrow dependency allows arbitrary code execution when loading a malicious data file

GHSA-x563-6hqv-26mr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ibis-framework 7.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files). This vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings. Note that Ibis itself makes extremely limited use of pyarrow.parquet.readtable: 1. readtable is used in tests, where the input file is entirely controlled by the Ibis developers 2. readtable is used in the ibis/examples/init.py as a fallback for backends that don't support reading Parquet directly. Parquet data used in ibis.examples are also managed by the Ibis developers. This Parquet data is generated from CSV files and SQLite databases. 3. The Pandas and Dask backends both use PyArrow to read Parquet files and are therefore affected. Ibis does not make use of APIs that directly read from either Arrow IPC files or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x563-6hqv-26mr

  2. Revision 1 · created ·

    Published from osv record GHSA-x563-6hqv-26mr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-x563-6hqv-26mr

Advisory: Ibis PyArrow dependency allows arbitrary code execution when loading a malicious data file
IDs: GHSA-x563-6hqv-26mr
Record: https://patchnext.com/advisories/ghsa-x563-6hqv-26mr (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ibis-framework 7.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ibis-framework: affected < 7.1.0; fixed in 7.1.0

## Suggested inspection (read-only)
- `python -m pip show ibis-framework`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ibis-framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x563-6hqv-26mr (OSV record GHSA-x563-6hqv-26mr lists affected ranges: PyPI ibis-framework >=0 <7.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-x563-6hqv-26mr (GitHub-reviewed advisory GHSA-x563-6hqv-26mr lists affected ranges: PyPI ibis-framework >=0 <7.1.0)

Commands are suggestions: review each one before running it.

Loading voting…