Skip to content

← Actionable
High, CVSS 8.1amended

PraisonAI: Cross-Origin Agent Execution via Hardcoded Wildcard CORS and Missing Authentication on AGUI Endpoint

GHSA-x462-jjpc-q4q4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonaiagents 4.5.128), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The AGUI endpoint (POST /agui) has no authentication and hardcodes Access-Control-Allow-Origin: on all responses. Combined with Starlette/FastAPI's Content-Type-agnostic JSON parsing, any website a victim visits can silently trigger arbitrary agent execution against a locally-running AGUI server and read the full response, including tool execution results and potentially sensitive data from the victim's environment. Details The vulnerability is a combination of three issues in src/praisonai-agents/praisonaiagents/ui/agui/agui.py: 1. No authentication (line 124-125): The endpoint accepts any request. RunAgentInput (defined in types.py:159-165) has no auth token, API key, or session validation field. No middleware or dependencies are attached to the router (line 111). 2. Hardcoded wildcard CORS (line 131-141): The Access-Control-Allow-Origin: header is hardcoded in the library code. Library consumers cannot override this without patching the source. 3. CORS preflight bypass via…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x462-jjpc-q4q4

  2. Revision 1 · created ·

    Published from osv record GHSA-x462-jjpc-q4q4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-x462-jjpc-q4q4

Advisory: PraisonAI: Cross-Origin Agent Execution via Hardcoded Wildcard CORS and Missing Authentication on AGUI Endpoint
IDs: GHSA-x462-jjpc-q4q4
Record: https://patchnext.com/advisories/ghsa-x462-jjpc-q4q4 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonaiagents 4.5.128. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonaiagents: affected < 4.5.128; fixed in 4.5.128

## Suggested inspection (read-only)
- `python -m pip show praisonaiagents`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonaiagents.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x462-jjpc-q4q4 (OSV record GHSA-x462-jjpc-q4q4 lists affected ranges: PyPI praisonaiagents >=0 <4.5.128 (fixed))
- Verified: https://github.com/advisories/GHSA-x462-jjpc-q4q4 (GitHub-reviewed advisory GHSA-x462-jjpc-q4q4 lists affected ranges: PyPI praisonaiagents >=0 <4.5.128)

Commands are suggestions: review each one before running it.

Loading voting…