ZendFramework SQL injection due to execution of platform-specific SQL containing interpolations
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendframework 2.1.4, 2.0.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zendframework/zendframework
- Affected
- >= 2.0.0, < 2.0.8>= 2.1.0, < 2.1.4
- Fixed in
- 2.0.8, 2.1.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x2f4-8wxf-w3vf lists affected ranges: Packagist zendframework/zendframework >=2.0.0 =2.1.0 <2.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The Zend\Db component in Zend Framework 2 provides platform abstraction, which is used in particular for SQL abstraction. Two methods defined in the platform interface, quoteValue() and quoteValueList(), allow users to manually quote values for creating SQL statements; these are in turn consumed by aspects of the SQL abstraction platform, including Zend\Db\Sql\Sql::getSqlStringForSqlObject(), and the getSqlString() method provided in a number of classes in the Zend\Db\Sql namespace. While these methods are primarily intended for debugging and logging purposes, developers can use them to produce SQL that is then passed to the driver to execute. Due to a flaw in how the quoteValue() and quoteValueList() methods were written, this can lead to potential SQL injection. The offending code is located in any of the Zend\Db\Adapter\Platform objects, particularly the quoteValue() and quoteValueList() methods. These methods did not take into account most of the possible escapable characters…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x2f4-8wxf-w3vf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-x2f4-8wxf-w3vf Advisory: ZendFramework SQL injection due to execution of platform-specific SQL containing interpolations IDs: GHSA-x2f4-8wxf-w3vf Record: https://patchnext.com/advisories/ghsa-x2f4-8wxf-w3vf (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zendframework/zendframework 2.1.4, 2.0.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zendframework/zendframework: affected >= 2.0.0, < 2.0.8; >= 2.1.0, < 2.1.4; fixed in 2.0.8, 2.1.4 ## Suggested inspection (read-only) - Packagist zendframework/zendframework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zendframework/zendframework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x2f4-8wxf-w3vf (GitHub-reviewed advisory GHSA-x2f4-8wxf-w3vf lists affected ranges: Packagist zendframework/zendframework >=2.0.0 =2.1.0 <2.1.4) Commands are suggestions: review each one before running it.
Loading voting…