Unsafe plugins can be installed via pack import by tenant admins
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@saltcorn/cli 0.8.8-beta.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @saltcorn/cli
- Affected
- < 0.8.8-beta.2
- Fixed in
- 0.8.8-beta.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wxf3-4fvj-vqqx lists affected ranges: npm @saltcorn/cli >=0 <0.8.8-beta.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wxf3-4fvj-vqqx lists affected ranges: npm @saltcorn/cli >=0 <0.8.8-beta.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Unsafe plugins (for instance sql-list) can be installed in subdomain tenants via pack import even if unsafe plugin installation for tenants is disables Details I have an example https://bot20230704.saltcorn.com/view/allplugins It's publicly accessible (but has not so secure values except list of tenants). But using this mech one can read any data from other tenants. Impact All tenants of installation (i.e. saltcorn.com), can be compromised from tenant user has admin access. If an untrusted user has admin rights to a tenant instance, they will be able to install a plug-in that can access information from other tenants Revived after 0.8.7 After patch in 0.8.7 this is not fixed completely. Here are steps to reproduce: 1. Publish to NPM plugin that was not approved by admin (in case of saltcorn.com) by @glutamate. I've just published this one: https://www.npmjs.com/package/saltcorn-qrcode 2. Publish somewhere plugin store that includes plugin from previous step:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wxf3-4fvj-vqqx
- Revision 1 · created ·
Published from osv record GHSA-wxf3-4fvj-vqqx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-wxf3-4fvj-vqqx Advisory: Unsafe plugins can be installed via pack import by tenant admins IDs: GHSA-wxf3-4fvj-vqqx Record: https://patchnext.com/advisories/ghsa-wxf3-4fvj-vqqx (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @saltcorn/cli 0.8.8-beta.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @saltcorn/cli: affected < 0.8.8-beta.2; fixed in 0.8.8-beta.2 ## Suggested inspection (read-only) - `npm ls @saltcorn/cli --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @saltcorn/cli. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wxf3-4fvj-vqqx (OSV record GHSA-wxf3-4fvj-vqqx lists affected ranges: npm @saltcorn/cli >=0 <0.8.8-beta.2 (fixed)) - Verified: https://github.com/advisories/GHSA-wxf3-4fvj-vqqx (GitHub-reviewed advisory GHSA-wxf3-4fvj-vqqx lists affected ranges: npm @saltcorn/cli >=0 <0.8.8-beta.2) Commands are suggestions: review each one before running it.
Loading voting…