Skip to content

← Actionable
Medium, CVSS 5.9

Potentially sensitive data exposure in Symfony Web Socket Bundle

GHSA-wwgf-3xp7-cxj4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gos/web-socket-bundle 3.3.0, 2.6.1, 1.10.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist gos/web-socket-bundle

    Affected
    < 1.10.4>= 2.0.0, < 2.6.1>= 3.0.0, < 3.3.0
    Fixed in
    3.3.0, 1.10.4, 2.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Inside Gos\Bundle\WebSocketBundle\Server\App\Dispatcher\TopicDispatcher::onPublish(), messages are arbitrarily broadcasted to the related Topic if Gos\Bundle\WebSocketBundle\Server\App\Dispatcher\TopicDispatcher::dispatch() does not succeed. The dispatch() method can be considered to not succeed if (depending on the version of the bundle) the callback defined on a topic route is misconfigured, a Gos\Bundle\WebSocketBundle\Topic\TopicInterface implementation is not found for the callback, a topic which also implements Gos\Bundle\WebSocketBundle\Topic\SecuredTopicInterface rejects the connection, or an Exception is unhandled. This can result in an unintended broadcast to the websocket server potentially with data that should be considered sensitive. Patches In 1.10.4, 2.6.1, and 3.3.0, Gos\Bundle\WebSocketBundle\Server\App\Dispatcher\TopicDispatcher::onPublish() has been changed to no longer broadcast an event's data if…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wwgf-3xp7-cxj4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-wwgf-3xp7-cxj4

Advisory: Potentially sensitive data exposure in Symfony Web Socket Bundle
IDs: GHSA-wwgf-3xp7-cxj4
Record: https://patchnext.com/advisories/ghsa-wwgf-3xp7-cxj4 (revision 1, source checked 26 Oct 2026, 13:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gos/web-socket-bundle 3.3.0, 2.6.1, 1.10.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist gos/web-socket-bundle: affected < 1.10.4; >= 2.0.0, < 2.6.1; >= 3.0.0, < 3.3.0; fixed in 3.3.0, 1.10.4, 2.6.1

## Suggested inspection (read-only)
- Packagist gos/web-socket-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gos/web-socket-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wwgf-3xp7-cxj4 (GitHub-reviewed advisory GHSA-wwgf-3xp7-cxj4 lists affected ranges: Packagist gos/web-socket-bundle >=0 =2.0.0 =3.0.0 <3.3.0)

Commands are suggestions: review each one before running it.

Loading voting…