Storing Password in Local Storage
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse 2.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse
- Affected
- < 2.10.0
- Fixed in
- 2.10.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wvh7-5p38-2qfc lists affected ranges: npm parse >=0 <2.10.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wvh7-5p38-2qfc lists affected ranges: npm parse >=0 <2.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The setPassword method (http://parseplatform.org/Parse-SDK-JS/api/2.9.1/Parse.User.html#setPassword) stores the user's password in localStorage as raw text making it vulnerable to anyone with access to your localStorage. We believe this is the only time that password is stored at all. In the documentation under Users Signing Up, it clearly states, "We never store passwords in plaintext, nor will we ever transmit passwords back to the client in plaintext." Example Code: After running the above code, the new password will be stored in localStorage as a property named "password". Proposed Solution: Before saving anything to localStorage, Parse should strip out any properties named "password" that are attempting to be stored with a Parse.User type object. Configuration: Parse SDK: 2.9.1 Parse Server: 3.9.0
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wvh7-5p38-2qfc
- Revision 1 · created ·
Published from osv record GHSA-wvh7-5p38-2qfc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-wvh7-5p38-2qfc Advisory: Storing Password in Local Storage IDs: GHSA-wvh7-5p38-2qfc Record: https://patchnext.com/advisories/ghsa-wvh7-5p38-2qfc (revision 2, source checked 26 Oct 2026, 12:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse 2.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse: affected < 2.10.0; fixed in 2.10.0 ## Suggested inspection (read-only) - `npm ls parse --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wvh7-5p38-2qfc (OSV record GHSA-wvh7-5p38-2qfc lists affected ranges: npm parse >=0 <2.10.0 (fixed)) - Verified: https://github.com/advisories/GHSA-wvh7-5p38-2qfc (GitHub-reviewed advisory GHSA-wvh7-5p38-2qfc lists affected ranges: npm parse >=0 <2.10.0) Commands are suggestions: review each one before running it.
Loading voting…