Pageflow vulnerable to sensitive user data extraction via Ransack query injection
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pageflow 15.7.1, 14.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems pageflow
- Affected
- < 14.5.2>= 15.0.0, < 15.7.1
- Fixed in
- 14.5.2, 15.7.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wrrw-crp8-979q lists affected ranges: RubyGems pageflow >=0 =15.0.0 <15.7.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact The attack allows extracting sensitive properties of database objects that are associated with users or entries belonging to an account that the attacker has access to. Pageflow uses the ActiveAdmin Ruby library to provide some management features to its users. ActiveAdmin relies on the Ransack library to implement search functionality. In its default configuration, Ransack will allow for query conditions based on properties of associated database objects [1]. The startswith, endswith or contains search matchers [2] can then be abused to exfiltrate sensitive string values of associated database objects via character-by-character brute-force. [1] https://activerecord-hackery.github.io/ransack/going-further/associations/ [2] https://activerecord-hackery.github.io/ransack/getting-started/search-matches/ Mitigation Upgrade to version 15.7.1 or 14.5.2 of the pageflow gem. For more information If you have any questions or comments about this advisory email us at info(at)codevise.de…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wrrw-crp8-979q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-wrrw-crp8-979q Advisory: Pageflow vulnerable to sensitive user data extraction via Ransack query injection IDs: GHSA-wrrw-crp8-979q Record: https://patchnext.com/advisories/ghsa-wrrw-crp8-979q (revision 1, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pageflow 15.7.1, 14.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems pageflow: affected < 14.5.2; >= 15.0.0, < 15.7.1; fixed in 14.5.2, 15.7.1 ## Suggested inspection (read-only) - RubyGems pageflow: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pageflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wrrw-crp8-979q (GitHub-reviewed advisory GHSA-wrrw-crp8-979q lists affected ranges: RubyGems pageflow >=0 =15.0.0 <15.7.1) Commands are suggestions: review each one before running it.
Loading voting…