Skip to content

← Actionable
Low, CVSS 0.6amended

neotoma has tenant isolation gap in relationship query endpoints

GHSA-wrr4-782v-jhwh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (neotoma 0.14.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm neotoma

    Affected
    >= 0.13.0, < 0.14.0
    Fixed in
    0.14.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
0.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The /listrelationships and /retrievegraphneighborhood endpoints call getAuthenticatedUserId (confirming a valid session exists) but do not pass the resolved user ID into the Supabase query as an .eq("userid", userId) filter. As a result, queries return rows from all users rather than scoping to the authenticated caller's data. Affected code /listrelationships (src/actions.ts): - Calls getAuthenticatedUserId but does not apply .eq("userid", userId) to the relationships query - Uses .or() string interpolation for entity ID matching without input validation /retrievegraphneighborhood (src/actions.ts): - Same pattern: auth resolved, user ID not applied to query filter Affected versions v0.13.0 Prerequisites 1. A valid authentication token for the Neotoma instance (attacker must have a legitimate account on the same instance) 2. A known entity ID belonging to another user (~96 bits of entropy — brute-force not practical) An unauthenticated caller is rejected at the auth middleware…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-wrr4-782v-jhwh

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-wrr4-782v-jhwh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-wrr4-782v-jhwh

Advisory: neotoma has tenant isolation gap in relationship query endpoints
IDs: GHSA-wrr4-782v-jhwh
Record: https://patchnext.com/advisories/ghsa-wrr4-782v-jhwh (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 0.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: neotoma 0.14.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm neotoma: affected >= 0.13.0, < 0.14.0; fixed in 0.14.0

## Suggested inspection (read-only)
- `npm ls neotoma --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on neotoma.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wrr4-782v-jhwh (OSV record GHSA-wrr4-782v-jhwh lists affected ranges: npm neotoma >=0.13.0 <0.14.0 (fixed))
- Verified: https://github.com/advisories/GHSA-wrr4-782v-jhwh (GitHub-reviewed advisory GHSA-wrr4-782v-jhwh lists affected ranges: npm neotoma >=0.13.0 <0.14.0)

Commands are suggestions: review each one before running it.

Loading voting…