Skip to content

← Actionable
Medium, CVSS 6.9

Lemmy user purging users or communities or banning users can delete images they didn't upload/exclusively use

GHSA-wr2m-38xh-rpc9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lemmy_server 0.19.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io lemmy_server

    Affected
    >= 0.17.0, < 0.19.11
    Fixed in
    0.19.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary An improper uploaded media ownership check can result in inadvertent deletion of media when a user is banned with content removal or purged. This can lead to deletion of media that was not uploaded by the banned/purged user. This also applies to purged communities, in which case all media posted in that community will get deleted without proper ownership check. This is limited to media with an image/ content-type returned by pict-rs. Details Lemmy did not associate users with media uploads until version 0.19.0 (#3927). Back when the first parts of content purging were implemented for 0.17.0 (#1809), it was therefore not possible to properly identify media belonging to a specific user for situations in which this data should get erased from pict-rs, Lemmy's media storage backend. Pict-rs deduplicates uploaded files transparently. As a result, it has two types of media deletion. A regular deletion will only remove the referenced alias, and if there are not other aliases…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wr2m-38xh-rpc9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-wr2m-38xh-rpc9

Advisory: Lemmy user purging users or communities or banning users can delete images they didn't upload/exclusively use
IDs: GHSA-wr2m-38xh-rpc9
Record: https://patchnext.com/advisories/ghsa-wr2m-38xh-rpc9 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lemmy_server 0.19.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io lemmy_server: affected >= 0.17.0, < 0.19.11; fixed in 0.19.11

## Suggested inspection (read-only)
- crates.io lemmy_server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lemmy_server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wr2m-38xh-rpc9 (GitHub-reviewed advisory GHSA-wr2m-38xh-rpc9 lists affected ranges: crates.io lemmy_server >=0.17.0 <0.19.11)

Commands are suggestions: review each one before running it.

Loading voting…