Skip to content

← Actionable
High, CVSS 7.5

PocketMine-MP has improperly handled dye colour IDs in banner NBT, leading to server crash

GHSA-wqqv-jcfr-9f5g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pocketmine/pocketmine-mp 4.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact DyeColorIdMap-fromId() did not account for the possibility that it might be given invalid input. This means that an undefined offset error would occur whenever this happened. This code is indirectly called during Banner-deserializeCompoundTag(), which is invoked when deserializing any item NBT, whether from network or disk. An attacker could use this bug to crash a server by providing NBT with invalid values for pattern colours in an inventory transaction, or by using /give to obtain an item with NBT like this. Patches 08b9495bce2d65a6d1d3eeb76e484499a00765eb Workarounds This is quite difficult to work around via a plugin. Theoretically, it's possible to override the Banner item class from a plugin and validate the data before it reaches deserializeCompoundTag(). For more information If you have any questions or comments about this advisory: Email us at security@pmmp.io

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wqqv-jcfr-9f5g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-wqqv-jcfr-9f5g

Advisory: PocketMine-MP has improperly handled dye colour IDs in banner NBT, leading to server crash
IDs: GHSA-wqqv-jcfr-9f5g
Record: https://patchnext.com/advisories/ghsa-wqqv-jcfr-9f5g (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pocketmine/pocketmine-mp 4.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pocketmine/pocketmine-mp: affected < 4.8.1; fixed in 4.8.1

## Suggested inspection (read-only)
- Packagist pocketmine/pocketmine-mp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pocketmine/pocketmine-mp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wqqv-jcfr-9f5g (GitHub-reviewed advisory GHSA-wqqv-jcfr-9f5g lists affected ranges: Packagist pocketmine/pocketmine-mp >=0 <4.8.1)

Commands are suggestions: review each one before running it.

Loading voting…