Skip to content

← Actionable
High, CVSS 8.8

Vulnerable version of libwebp and can be exploited with a malicious source image

GHSA-wqcr-xm43-hpqr

What to do

Vendor response not established. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet imageresizer.plugins.freeimage

    Affected
    <= 4.2.8
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact This vulnerability affects deployments of FreeImage that involve decoding or processing malicious source .webp files. If you only process your own trusted files, this should not affect you, but you should remove FreeImage from your project, as it is not maintained and presents a massive security risk. If you are using FreeImage via ImageResizer.Plugins.FreeImage, please utilize Imageflow or Imageflow.Server instead, or upgrade to ImageResizer 5 and use ImageResizer.Plugins.Imageflow (enable Prereleases on NuGet to access). FreeImage relies on Google's libwebp library to decode .webp images, and is affected by the recent zero-day out-of-bounds write vulnerability CVE-2023-4863 and https://github.com/advisories/GHSA-j7hp-h8jx-5ppr. The libwebp vulnerability also affects Chrome, Android, macOS, and other consumers of the library). libwebp patched the vulnerability and released 1.3.2. FreeImage hasn't been updated since then and is presumed vulnerable. Patches None. FreeImage has…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wqcr-xm43-hpqr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-wqcr-xm43-hpqr

Advisory: Vulnerable version of libwebp and can be exploited with a malicious source image
IDs: GHSA-wqcr-xm43-hpqr
Record: https://patchnext.com/advisories/ghsa-wqcr-xm43-hpqr (revision 1, source checked 26 Oct 2026, 16:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor response not established. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet imageresizer.plugins.freeimage: affected <= 4.2.8

## Suggested inspection (read-only)
- NuGet imageresizer.plugins.freeimage: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on imageresizer.plugins.freeimage.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wqcr-xm43-hpqr (GitHub-reviewed advisory GHSA-wqcr-xm43-hpqr lists affected ranges: NuGet imageresizer.plugins.freeimage >=0 <=4.2.8)

Commands are suggestions: review each one before running it.

Loading voting…