laravel framework SQL Injection via limit and offset functions
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (laravel/framework 8.40.0, 7.30.5, 6.20.26), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist laravel/framework
- Affected
- >= 6.0.0, < 6.20.26>= 7.0.0, < 7.30.5>= 8.0.0, < 8.40.0
- Fixed in
- 6.20.26, 7.30.5, 8.40.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wq8p-mqvg-2p5h lists affected ranges: Packagist laravel/framework >=6.0.0 =7.0.0 =8.0.0 <8.40.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Those using SQL Server with Laravel and allowing user input to be passed directly to the limit and offset functions are vulnerable to SQL injection. Other database drivers such as MySQL and Postgres are not affected by this vulnerability. Patches This problem has been patched on Laravel versions 6.20.26, 7.30.5, and 8.40.0. Workarounds You may workaround this vulnerability by ensuring that only integers are passed to the limit and offset functions, as well as the skip and take functions.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wq8p-mqvg-2p5h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-wq8p-mqvg-2p5h Advisory: laravel framework SQL Injection via limit and offset functions IDs: GHSA-wq8p-mqvg-2p5h Record: https://patchnext.com/advisories/ghsa-wq8p-mqvg-2p5h (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: laravel/framework 8.40.0, 7.30.5, 6.20.26. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist laravel/framework: affected >= 6.0.0, < 6.20.26; >= 7.0.0, < 7.30.5; >= 8.0.0, < 8.40.0; fixed in 6.20.26, 7.30.5, 8.40.0 ## Suggested inspection (read-only) - Packagist laravel/framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on laravel/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wq8p-mqvg-2p5h (GitHub-reviewed advisory GHSA-wq8p-mqvg-2p5h lists affected ranges: Packagist laravel/framework >=6.0.0 =7.0.0 =8.0.0 <8.40.0) Commands are suggestions: review each one before running it.
Loading voting…