Skip to content

← Actionable
Medium, CVSS 6.5amended

SurrealDB: USE NS/DB implicit creation bypasses DEFINE authorization

CVE-2026-63741GHSA-wp87-mgvq-5j93

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (surrealdb 3.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io surrealdb

    Affected
    < 3.1.0
    Fixed in
    3.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
EPSS
  • CVE-2026-63741: 0.37% estimated exploitation activity in the next 30 days; percentile 30.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An anonymous caller could create new namespaces and databases on a running SurrealDB instance without holding `DEFINE NAMESPACE` or `DEFINE DATABASE` permission. `USE NS ` and `USE DB ` automatically create the target when it does not exist. The three places `USE` is handled — the RPC `use` method, `Datastore::process_use`, and the SurrealQL executor — did not check whether the caller was allowed to create the resource. Under default capabilities any session reached this path, including an unauthenticated guest.

Impact What an attacker can do: - Create new namespaces and databases without `DEFINE NAMESPACE` / `DEFINE DATABASE` permission. An unauthenticated guest is enough under default capabilities. - Recreate a parent namespace that an operator deliberately dropped, using a stale namespace-Editor token, by running `USE NS DB anything`. - Exhaust catalog storage by repeatedly creating new resources. What it can't do: - Read or modify data inside any pre-existing…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-wp87-mgvq-5j93

  2. Revision 1 · created ·

    Published from ghsa record GHSA-wp87-mgvq-5j93

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-63741

Advisory: SurrealDB: USE NS/DB implicit creation bypasses DEFINE authorization
IDs: CVE-2026-63741, GHSA-wp87-mgvq-5j93
Record: https://patchnext.com/advisories/ghsa-wp87-mgvq-5j93 (revision 2, source checked 4 Nov 2026, 06:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: surrealdb 3.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io surrealdb: affected < 3.1.0; fixed in 3.1.0

## Suggested inspection (read-only)
- crates.io surrealdb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on surrealdb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wp87-mgvq-5j93 (GitHub-reviewed advisory GHSA-wp87-mgvq-5j93 lists affected ranges: crates.io surrealdb >=0 <3.1.0)
- Verified: https://osv.dev/vulnerability/GHSA-wp87-mgvq-5j93 (OSV record GHSA-wp87-mgvq-5j93 lists affected ranges: crates.io surrealdb >=0 <3.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…