Skip to content

← Actionable
Medium, CVSS 6.5amended

Nodemailer: IDN/Punycode domain allow-list bypass leads to email delivery to an attacker-controlled domain

CVE-2026-92598GHSA-wmmp-3585-3rmp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nodemailer 9.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-92598: 0.40% estimated exploitation activity in the next 30 days; percentile 33.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Nodemailer resolves an international (IDN / non-ASCII) recipient domain to a different Punycode xn-- label than every UTS‑46‑conformant parser (web browsers, the WHATWG URL Standard, Node's url.domainToASCII, Python's idna). Its address normalizer (normalizeAddress in lib/mime-node/index.js) uses the bundled raw RFC‑3492 Punycode codec with no UTS‑46 mapping/normalization, so a domain that a standards‑compliant validator maps to a trusted domain is delivered by Nodemailer to a different, attacker‑registrable domain. An application that applies a domain allow‑list / same‑domain check to a recipient using a normal IDN‑aware parser (or that shows the normalized recipient to a user for confirmation) and then relies on Nodemailer to deliver to that domain can be induced to send email to an unintended external domain. This is the same weakness class as CVE‑2025‑13033 (Interpretation Conflict, CWE‑436) but reached through IDN/Punycode rather than quoted local‑parts, and it is not…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-wmmp-3585-3rmp

  2. Revision 2 · amended ·

    Amended from osv record GHSA-wmmp-3585-3rmp

  3. Revision 1 · created ·

    Published from ghsa record GHSA-wmmp-3585-3rmp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-92598

Advisory: Nodemailer: IDN/Punycode domain allow-list bypass leads to email delivery to an attacker-controlled domain
IDs: CVE-2026-92598, GHSA-wmmp-3585-3rmp
Record: https://patchnext.com/advisories/ghsa-wmmp-3585-3rmp (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nodemailer 9.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nodemailer: affected < 9.1.0; fixed in 9.1.0

## Suggested inspection (read-only)
- `npm ls nodemailer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nodemailer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wmmp-3585-3rmp (GitHub-reviewed advisory GHSA-wmmp-3585-3rmp lists affected ranges: npm nodemailer >=0 <9.1.0)
- Verified: https://osv.dev/vulnerability/GHSA-wmmp-3585-3rmp (OSV record GHSA-wmmp-3585-3rmp lists affected ranges: npm nodemailer >=0 <9.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…