@vendure/core's insecure currencyCode handling allows wrong payment amounts
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@vendure/core 2.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @vendure/core
- Affected
- < 2.1.3
- Fixed in
- 2.1.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wm63-7627-ch33 lists affected ranges: npm @vendure/core >=0 <2.1.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wm63-7627-ch33 lists affected ranges: npm @vendure/core >=0 <2.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Currently, in many Vendure deployments it's possible to select any currencyCode (really any, doesn't need to be assigned to the channel) and pay through Mollie and Stripe in that particular currencyCode. The prices are not transformed. The result is the Order is in Payment Settled in the foreign currency. See SS, CZK is not in the channel. I've tested with Mollie and Stripe it both works. Further notes After looking into this further and with help from the comments below, the root cause of this vulnerability is the ability to specify an arbitrary currencyCode as a query parameter to an API call, and then Vendure will use this and pass it to the rest of the system as RequestContext.currencyCode. The solution is to add validation to the passed currencyCode to ensure that it matches one of the available availableCurrencyCodes of the active Channel. Furthermore, an additional check has been added for when the currencyCode changes during the AddingItems stage - in this case we need…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wm63-7627-ch33
- Revision 1 · created ·
Published from osv record GHSA-wm63-7627-ch33
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-wm63-7627-ch33 Advisory: @vendure/core's insecure currencyCode handling allows wrong payment amounts IDs: GHSA-wm63-7627-ch33 Record: https://patchnext.com/advisories/ghsa-wm63-7627-ch33 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @vendure/core 2.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @vendure/core: affected < 2.1.3; fixed in 2.1.3 ## Suggested inspection (read-only) - `npm ls @vendure/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @vendure/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wm63-7627-ch33 (OSV record GHSA-wm63-7627-ch33 lists affected ranges: npm @vendure/core >=0 <2.1.3 (fixed)) - Verified: https://github.com/advisories/GHSA-wm63-7627-ch33 (GitHub-reviewed advisory GHSA-wm63-7627-ch33 lists affected ranges: npm @vendure/core >=0 <2.1.3) Commands are suggestions: review each one before running it.
Loading voting…