pREST vulnerable to jwt bypass + sql injection
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/prest/prest 1.5.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.5.4
- Fixed in
- 1.5.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wm25-j4gw-6vr3 lists affected ranges: Go github.com/prest/prest >=0 <1.5.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Probably jwt bypass + sql injection or what i'm doing wrong? PoC (how to reproduce) 1. Create following files: docker-compose.yml: Dockerfile: prest.toml: 2. run commands: wait for pg and prest, then run following to add test data to the pg: 3. SQL injection even without jwt token: output:
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wm25-j4gw-6vr3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-wm25-j4gw-6vr3 Advisory: pREST vulnerable to jwt bypass + sql injection IDs: GHSA-wm25-j4gw-6vr3 Record: https://patchnext.com/advisories/ghsa-wm25-j4gw-6vr3 (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/prest/prest 1.5.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/prest/prest: affected < 1.5.4; fixed in 1.5.4 ## Suggested inspection (read-only) - Go github.com/prest/prest: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/prest/prest. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wm25-j4gw-6vr3 (GitHub-reviewed advisory GHSA-wm25-j4gw-6vr3 lists affected ranges: Go github.com/prest/prest >=0 <1.5.4) Commands are suggestions: review each one before running it.
Loading voting…