Unhandled exception when decoding form response JSON
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pocketmine/pocketmine-mp 4.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pocketmine/pocketmine-mp
- Affected
- >= 4.0.0, < 4.0.7
- Fixed in
- 4.0.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wjfq-88q2-r34j lists affected ranges: Packagist pocketmine/pocketmine-mp >=4.0.0 <4.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact When handling form responses from the client (ModalFormResponsePacket), the Minecraft Windows client may send weird JSON that jsondecode() can't understand. A workaround for this is implemented in InGamePacketHandler::stupidjsondecode(). An InvalidArgumentException is thrown by this function when it fails to fix an error found in the JSON, which is not caught by the caller. This leads to a server crash. Patches 56fe71d939c38fe14e18a31a673a9331bcc0e4ca Workarounds A plugin may handle DataPacketReceiveEvent, capture ModalFormResponsePacket and run the provided JSON through stupidjsondecode. Note that this requires copying the body of the function to a plugin, since the function is currently private. For more information If you have any questions or comments about this advisory: Email us at team@pmmp.io
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wjfq-88q2-r34j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-wjfq-88q2-r34j Advisory: Unhandled exception when decoding form response JSON IDs: GHSA-wjfq-88q2-r34j Record: https://patchnext.com/advisories/ghsa-wjfq-88q2-r34j (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pocketmine/pocketmine-mp 4.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pocketmine/pocketmine-mp: affected >= 4.0.0, < 4.0.7; fixed in 4.0.7 ## Suggested inspection (read-only) - Packagist pocketmine/pocketmine-mp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pocketmine/pocketmine-mp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wjfq-88q2-r34j (GitHub-reviewed advisory GHSA-wjfq-88q2-r34j lists affected ranges: Packagist pocketmine/pocketmine-mp >=4.0.0 <4.0.7) Commands are suggestions: review each one before running it.
Loading voting…