Skip to content

← Actionable
Medium, CVSS 6.8amended

CSRF Vulnerability in polaris-website

GHSA-whrh-9j4q-g7ph

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (polaris-website 1.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact CSRF vulnerability: In some very specific circumstances, an attacker would be able to update your settings. Basically you would need to navigate to hackersite.com while logged into our panel. Then they could modify your settings. They couldn't check if it worked, nor could they read your settings. Patches As of v1.1.1 this has been patched by implementing the Double submit pattern using a cookie. For more information If you have any questions or comments about this advisory: Open an issue in Polaris-React Email us at hi@nezto.re Join our discord (preferred): https://discord.gg/QevWabU

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-whrh-9j4q-g7ph

  2. Revision 1 · created ·

    Published from osv record GHSA-whrh-9j4q-g7ph

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-whrh-9j4q-g7ph

Advisory: CSRF Vulnerability in polaris-website
IDs: GHSA-whrh-9j4q-g7ph
Record: https://patchnext.com/advisories/ghsa-whrh-9j4q-g7ph (revision 2, source checked 26 Oct 2026, 12:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: polaris-website 1.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm polaris-website: affected < 1.1.1; fixed in 1.1.1

## Suggested inspection (read-only)
- `npm ls polaris-website --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on polaris-website.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-whrh-9j4q-g7ph (OSV record GHSA-whrh-9j4q-g7ph lists affected ranges: npm polaris-website >=0 <1.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-whrh-9j4q-g7ph (GitHub-reviewed advisory GHSA-whrh-9j4q-g7ph lists affected ranges: npm polaris-website >=0 <1.1.1)

Commands are suggestions: review each one before running it.

Loading voting…