GitPython: --no-index bypasses diff unsafe-option protections and enables a blind local-file content oracle
CVE-2026-87818GHSA-whh4-5q6c-9v3x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gitpython 3.1.60), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI gitpython
- Affected
- >= 3.1.59, < 3.1.60
- Fixed in
- 3.1.60
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-whh4-5q6c-9v3x lists affected ranges: PyPI gitpython >=3.1.59 <3.1.60
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-whh4-5q6c-9v3x lists affected ranges: PyPI gitpython >=3.1.59 <3.1.60 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-87818: 0.41% estimated exploitation activity in the next 30 days; percentile 35.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary GitPython 3.1.59 blocks a previously available local-file read path through unsafe git diff options such as -O/--orderfile. However, the high-level diff API still permits --no-index with the default allowunsafeoptions=False. --no-index changes the semantics of the paths arguments: instead of repository-relative pathspecs, Git interprets them as arbitrary filesystem paths. When combined with the still-allowed -I/--ignore-matching-lines option, this creates a content-dependent Boolean oracle over a caller-selected local file. This was reproduced against the published GitPython 3.1.59 wheel. The original unsafe-option path is blocked in 3.1.59, while this alternate path remains reachable without setting allowunsafeoptions=True. Details Confirmed API surface: repo.index.diff( None, noindex=True, I=pattern, paths=[baselinepath, targetpath], createpatch=True, ) The relevant behavior is: 1. --no-index makes the two values supplied via paths filesystem operands rather than repository…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-whh4-5q6c-9v3x
- Revision 2 · amended ·
Amended from osv record GHSA-whh4-5q6c-9v3x
- Revision 1 · created ·
Published from ghsa record GHSA-whh4-5q6c-9v3x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-87818 Advisory: GitPython: --no-index bypasses diff unsafe-option protections and enables a blind local-file content oracle IDs: CVE-2026-87818, GHSA-whh4-5q6c-9v3x Record: https://patchnext.com/advisories/ghsa-whh4-5q6c-9v3x (revision 3, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gitpython 3.1.60. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI gitpython: affected >= 3.1.59, < 3.1.60; fixed in 3.1.60 ## Suggested inspection (read-only) - `python -m pip show gitpython`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gitpython. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-whh4-5q6c-9v3x (GitHub-reviewed advisory GHSA-whh4-5q6c-9v3x lists affected ranges: PyPI gitpython >=3.1.59 <3.1.60) - Verified: https://osv.dev/vulnerability/GHSA-whh4-5q6c-9v3x (OSV record GHSA-whh4-5q6c-9v3x lists affected ranges: PyPI gitpython >=3.1.59 <3.1.60 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…