@account-kit/smart-contracts Allowlist Module Bypass Vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@account-kit/smart-contracts 4.28.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @account-kit/smart-contracts
- Affected
- >= 4.8.0, < 4.28.2
- Fixed in
- 4.28.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wfm2-rq5g-f8v5 lists affected ranges: npm @account-kit/smart-contracts >=4.8.0 <4.28.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wfm2-rq5g-f8v5 lists affected ranges: npm @account-kit/smart-contracts >=4.8.0 <4.28.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Allowlist module contains a bypass vulnerability Details The logic for using an allowlist on a Modular Account V2 contained a bug that allowed session keys to bypass any allowlist configuration Action If you are using @aa-sdk and/or @account-kit/smart-contracts between the versions of =4.8.0 and <4.28.1, please upgrade to 4.28.2
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wfm2-rq5g-f8v5
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-wfm2-rq5g-f8v5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-wfm2-rq5g-f8v5 Advisory: @account-kit/smart-contracts Allowlist Module Bypass Vulnerability IDs: GHSA-wfm2-rq5g-f8v5 Record: https://patchnext.com/advisories/ghsa-wfm2-rq5g-f8v5 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @account-kit/smart-contracts 4.28.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @account-kit/smart-contracts: affected >= 4.8.0, < 4.28.2; fixed in 4.28.2 ## Suggested inspection (read-only) - `npm ls @account-kit/smart-contracts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @account-kit/smart-contracts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wfm2-rq5g-f8v5 (OSV record GHSA-wfm2-rq5g-f8v5 lists affected ranges: npm @account-kit/smart-contracts >=4.8.0 <4.28.2 (fixed)) - Verified: https://github.com/advisories/GHSA-wfm2-rq5g-f8v5 (GitHub-reviewed advisory GHSA-wfm2-rq5g-f8v5 lists affected ranges: npm @account-kit/smart-contracts >=4.8.0 <4.28.2) Commands are suggestions: review each one before running it.
Loading voting…