Hydra legacy target blacklist permits unsafe PyYAML loading
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (hydra-core 1.4.0rc3, 1.3.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI hydra-core
- Affected
- >= 1.3.6, < 1.3.8>= 1.4.0.dev9, < 1.4.0rc3
- Fixed in
- 1.4.0rc3, 1.3.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wf6j-7hvr-gr93 lists affected ranges: PyPI hydra-core >=1.3.6 =1.4.0.dev9 <1.4.0rc3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wf6j-7hvr-gr93 lists affected ranges: PyPI hydra-core >=1.3.6 =1.4.0.dev9 <1.4.0rc3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Hydra's legacy target blacklist omits PyYAML's unsafe loading surfaces. If an application passes attacker-controlled targets and arguments to instantiate(), a target such as yaml.unsafe_load can execute Python code through a config-controlled YAML stream containing Python object-construction tags.
Impact and prerequisites The attacker must control the relevant target and arguments that the application instantiates. The configured callable executes with the application's process privileges. This is a gap in the best-effort legacy blacklist. It is not a bypass of Hydra 1.4's execution whitelist supplied by trusted Python code. One realistic exposure is a model downloaded from a third-party repository, such as Hugging Face, that bundles attacker-controlled configuration. When a victim loads the model using application code that passes this configuration to legacy Hydra instantiation without effective target restrictions, the model's metadata can execute code in the victim…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-wf6j-7hvr-gr93
- Revision 1 · created ·
Published from ghsa record GHSA-wf6j-7hvr-gr93
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-wf6j-7hvr-gr93 Advisory: Hydra legacy target blacklist permits unsafe PyYAML loading IDs: GHSA-wf6j-7hvr-gr93 Record: https://patchnext.com/advisories/ghsa-wf6j-7hvr-gr93 (revision 2, source checked 28 Oct 2026, 06:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: hydra-core 1.4.0rc3, 1.3.8. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI hydra-core: affected >= 1.3.6, < 1.3.8; >= 1.4.0.dev9, < 1.4.0rc3; fixed in 1.4.0rc3, 1.3.8 ## Suggested inspection (read-only) - `python -m pip show hydra-core`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on hydra-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wf6j-7hvr-gr93 (GitHub-reviewed advisory GHSA-wf6j-7hvr-gr93 lists affected ranges: PyPI hydra-core >=1.3.6 =1.4.0.dev9 <1.4.0rc3) - Verified: https://osv.dev/vulnerability/GHSA-wf6j-7hvr-gr93 (OSV record GHSA-wf6j-7hvr-gr93 lists affected ranges: PyPI hydra-core >=1.3.6 =1.4.0.dev9 <1.4.0rc3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…