devalue: Sparse arrays emitted by uneval cause eager allocation when evaluated
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (devalue 5.9.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm devalue
- Affected
- >= 1.0.0, <= 5.9.2
- Fixed in
- 5.9.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wf3x-273g-mvxv lists affected ranges: npm devalue >=1.0.0 <=5.9.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wf3x-273g-mvxv lists affected ranges: npm devalue >=1.0.0 <5.9.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:N/SA:L · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Evaluating legitimate uneval output for a sparse array can allocate memory proportional to its declared length. A tiny serialized value can therefore cause large memory allocation in a consuming browser/runtime. This occurs during evaluation of generated code, not in default parse sparse-array construction. You would only be affected by this if you were serializing very large sparse arrays and then evaluating the results. In the general use case for uneval of sending data to the client, the worst that could happen is the browser tab running out of memory.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-wf3x-273g-mvxv
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-wf3x-273g-mvxv
- Revision 1 · created ·
Published from ghsa record GHSA-wf3x-273g-mvxv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-wf3x-273g-mvxv Advisory: devalue: Sparse arrays emitted by uneval cause eager allocation when evaluated IDs: GHSA-wf3x-273g-mvxv Record: https://patchnext.com/advisories/ghsa-wf3x-273g-mvxv (revision 4, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: devalue 5.9.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm devalue: affected >= 1.0.0, <= 5.9.2; fixed in 5.9.3 ## Suggested inspection (read-only) - `npm ls devalue --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on devalue. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wf3x-273g-mvxv (GitHub-reviewed advisory GHSA-wf3x-273g-mvxv lists affected ranges: npm devalue >=1.0.0 <=5.9.2) - Verified: https://osv.dev/vulnerability/GHSA-wf3x-273g-mvxv (OSV record GHSA-wf3x-273g-mvxv lists affected ranges: npm devalue >=1.0.0 <5.9.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…