@eeacms/volto-chatbot has Unauthenticated Danswer API Confused Deputy Proxy
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@eeacms/volto-chatbot 2.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.0.4
- Fixed in
- 2.0.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w9x9-j56r-h98r lists affected ranges: npm @eeacms/volto-chatbot >=0 <=2.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w9x9-j56r-h98r lists affected ranges: npm @eeacms/volto-chatbot >=0 <2.0.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Unauthenticated Danswer API Confused Deputy Proxy in @eeacms/volto-chatbot
Summary `@eeacms/volto-chatbot` exposes an Express middleware route (`/_v1_da/`) that accepts unauthenticated HTTP requests from any network client and proxies them to the configured upstream Danswer API, automatically attaching the server-side service credentials (`DANSWER_API_KEY` or session cookie). Because no authorization check, path allowlist, or method restriction is applied before the upstream request is issued, an unauthenticated attacker can invoke arbitrary Danswer API operations — including privileged admin endpoints — as the configured service account. This is a classic Confused Deputy attack: the Volto proxy acts as a deputy that carries credentials on behalf of the attacker.
Details The vulnerability is introduced across two source files in `@eeacms/volto-chatbot@2.0.3`. Route registration (`src/index.js:15`): ```js middleware.all('/_v1_da/', proxyMiddleware); ``` The…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-w9x9-j56r-h98r
- Revision 1 · created ·
Published from ghsa record GHSA-w9x9-j56r-h98r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-w9x9-j56r-h98r Advisory: @eeacms/volto-chatbot has Unauthenticated Danswer API Confused Deputy Proxy IDs: GHSA-w9x9-j56r-h98r Record: https://patchnext.com/advisories/ghsa-w9x9-j56r-h98r (revision 2, source checked 30 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @eeacms/volto-chatbot 2.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @eeacms/volto-chatbot: affected < 2.0.4; fixed in 2.0.4 ## Suggested inspection (read-only) - `npm ls @eeacms/volto-chatbot --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @eeacms/volto-chatbot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w9x9-j56r-h98r (GitHub-reviewed advisory GHSA-w9x9-j56r-h98r lists affected ranges: npm @eeacms/volto-chatbot >=0 <=2.0.3) - Verified: https://osv.dev/vulnerability/GHSA-w9x9-j56r-h98r (OSV record GHSA-w9x9-j56r-h98r lists affected ranges: npm @eeacms/volto-chatbot >=0 <2.0.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…