Skip to content

← Actionable
Unrated

eZ Platform Admin UI is vulnerable to Cross-site Scripting (XSS)

GHSA-w9p3-26fx-5mp3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/platform-ui-assets-bundle 4.2.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

There is an XSS vulnerability in CKEditor, which is used by AlloyEditor, which is used in eZ Platform Admin UI. Scripts can be injected through specially crafted "protected" comments. We are not sure it is exploitable in eZ Platform, but recommend installing it to be on the safe side. It is fixed in CKEditor v4.14, AlloyEditor v2.11.9. It is distributed via Composer, for: Drafts that are sent to trash become visible in the Review Queue, even for users that were not able to see them before this action. It's not possible to preview them, but their title and review history is displayed. This affects Enterprise Edition only, of which ezplatform-workflow is a part. This security update is distributed via Composer, for

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w9p3-26fx-5mp3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-w9p3-26fx-5mp3

Advisory: eZ Platform Admin UI is vulnerable to Cross-site Scripting (XSS)
IDs: GHSA-w9p3-26fx-5mp3
Record: https://patchnext.com/advisories/ghsa-w9p3-26fx-5mp3 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ezsystems/platform-ui-assets-bundle 4.2.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist ezsystems/platform-ui-assets-bundle: affected >= 4.2.0, < 4.2.3; fixed in 4.2.3

## Suggested inspection (read-only)
- Packagist ezsystems/platform-ui-assets-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ezsystems/platform-ui-assets-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w9p3-26fx-5mp3 (GitHub-reviewed advisory GHSA-w9p3-26fx-5mp3 lists affected ranges: Packagist ezsystems/platform-ui-assets-bundle >=4.2.0 <4.2.3)

Commands are suggestions: review each one before running it.

Loading voting…