Skip to content

← Actionable
High, CVSS 7.3amended

Paperclip: Malicious skills able to exfiltrate and destroy all user data

GHSA-w8hx-hqjv-vjcq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@paperclipai/server 2026.416.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary An arbitrary code execution vulnerability in the workspace runtime service allows any agent to execute shell commands on the server, exposing all environment variables including API keys, JWT secrets, and database credentials. Details A malicious skill can instruct the agent to exploit the workspace runtime service feature, which allows arbitrary shell command execution on the server. Vulnerable Code Path 1. Agent calls PATCH /api/projects/{projectId}/workspaces/{workspaceId} to set a malicious runtimeConfig 2. Agent calls POST /api/projects/{projectId}/workspaces/{workspaceId}/runtime-services/start 3. Server executes the command via spawn() in server/src/services/workspace-runtime.ts: The command parameter comes directly from workspace config with no sanitization, allowing arbitrary code execution in the server's process context. Attack Flow The attached skill (disguised as a "system health diagnostic") instructs the agent to: 1. Create a workspace with a malicious runtime…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w8hx-hqjv-vjcq

  2. Revision 1 · created ·

    Published from osv record GHSA-w8hx-hqjv-vjcq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-w8hx-hqjv-vjcq

Advisory: Paperclip: Malicious skills able to exfiltrate and destroy all user data
IDs: GHSA-w8hx-hqjv-vjcq
Record: https://patchnext.com/advisories/ghsa-w8hx-hqjv-vjcq (revision 2, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @paperclipai/server 2026.416.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @paperclipai/server: affected < 2026.416.0; fixed in 2026.416.0

## Suggested inspection (read-only)
- `npm ls @paperclipai/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @paperclipai/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w8hx-hqjv-vjcq (OSV record GHSA-w8hx-hqjv-vjcq lists affected ranges: npm @paperclipai/server >=0 <2026.416.0 (fixed))
- Verified: https://github.com/advisories/GHSA-w8hx-hqjv-vjcq (GitHub-reviewed advisory GHSA-w8hx-hqjv-vjcq lists affected ranges: npm @paperclipai/server >=0 <2026.416.0)

Commands are suggestions: review each one before running it.

Loading voting…