Silverstripe Forum Module CSRF Vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/forum 0.7.4, 0.6.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/forum
- Affected
- <= 0.6.1>= 0.7.0, <= 0.7.3
- Fixed in
- 0.7.4, 0.6.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w8fq-xgvh-cxc2 lists affected ranges: Packagist silverstripe/forum >=0 =0.7.0 <=0.7.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
A number of form actions in the Forum module are directly accessible. A malicious user (e.g. spammer) can use GET requests to create Members and post to forums, bypassing CSRF and anti-spam measures. Additionally, a forum moderator could be tricked into clicking a specially crafted URL, resulting in a topic being moved. Thanks to Michael Strong for discovering.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w8fq-xgvh-cxc2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-w8fq-xgvh-cxc2 Advisory: Silverstripe Forum Module CSRF Vulnerability IDs: GHSA-w8fq-xgvh-cxc2 Record: https://patchnext.com/advisories/ghsa-w8fq-xgvh-cxc2 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/forum 0.7.4, 0.6.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/forum: affected <= 0.6.1; >= 0.7.0, <= 0.7.3; fixed in 0.7.4, 0.6.2 ## Suggested inspection (read-only) - Packagist silverstripe/forum: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/forum. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w8fq-xgvh-cxc2 (GitHub-reviewed advisory GHSA-w8fq-xgvh-cxc2 lists affected ranges: Packagist silverstripe/forum >=0 =0.7.0 <=0.7.3) Commands are suggestions: review each one before running it.
Loading voting…