Phlex XSS protection bypass via attribute splatting, dynamic tags, and href values
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phlex 2.4.1, 2.3.2, 2.2.2, 2.1.3, 2.0.2, 1.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems phlex
- Affected
- >= 2.4.0.beta1, < 2.4.1>= 2.3.0, < 2.3.2>= 2.2.0, < 2.2.2>= 2.1.0, < 2.1.3>= 2.0.0.beta1, < 2.0.2< 1.11.1
- Fixed in
- 2.4.1, 2.1.3, 2.2.2, 2.0.2, 1.11.1, 2.3.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w67g-2h6v-vjgq lists affected ranges: RubyGems phlex >=2.4.0.beta1 =2.3.0 =2.2.0 =2.1.0 =2.0.0.beta1 =0 <1.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact During a security audit conducted with Claude Opus 4.6 and GPT-5.3-Codex, we identified three specific ways to bypass the XSS (cross-site-scripting) protection built into Phlex. 1. The first bypass could happen if user-provided attributes with string keys were splatted into HTML tag, e.g. div(userattributes). 2. The second bypass could happen if user-provided tag names were passed to the tag method, e.g. tag(sometagnamefromuser). 3. The third bypass could happen if user’s links were passed to href attributes, e.g. a(href: userprovidedlink). All three of these patterns are meant to be safe and all have now been patched. Patches Phlex has patched all three issues and introduced new tests that run against Safari, Firefox and Chrome. The patched versions are: - 2.4.1 - 2.3.2 - 2.2.2 - 2.1.3 - 2.0.2 - 1.11.1 Phlex has also patched the main branch in GitHub. Workarounds If a project uses a secure CSP (content security policy) or if the application doesn’t use any of the above…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w67g-2h6v-vjgq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-w67g-2h6v-vjgq Advisory: Phlex XSS protection bypass via attribute splatting, dynamic tags, and href values IDs: GHSA-w67g-2h6v-vjgq Record: https://patchnext.com/advisories/ghsa-w67g-2h6v-vjgq (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phlex 2.4.1, 2.3.2, 2.2.2, 2.1.3, 2.0.2, 1.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems phlex: affected >= 2.4.0.beta1, < 2.4.1; >= 2.3.0, < 2.3.2; >= 2.2.0, < 2.2.2; >= 2.1.0, < 2.1.3; >= 2.0.0.beta1, < 2.0.2; < 1.11.1; fixed in 2.4.1, 2.1.3, 2.2.2, 2.0.2, 1.11.1, 2.3.2 ## Suggested inspection (read-only) - RubyGems phlex: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phlex. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w67g-2h6v-vjgq (GitHub-reviewed advisory GHSA-w67g-2h6v-vjgq lists affected ranges: RubyGems phlex >=2.4.0.beta1 =2.3.0 =2.2.0 =2.1.0 =2.0.0.beta1 =0 <1.11.1) Commands are suggestions: review each one before running it.
Loading voting…