go-git: Malformed Git object data may cause panics or resource exhaustion
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/go-git/go-git/v6 6.0.0-alpha.4; github.com/go-git/go-git/v5 5.19.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/go-git/go-git/v6
- Affected
- <= 6.0.0-alpha.3
- Fixed in
- 6.0.0-alpha.4
Go github.com/go-git/go-git/v5
- Affected
- <= 5.19.0
- Fixed in
- 5.19.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w5pp-99ch-qj29 lists affected ranges: Go github.com/go-git/go-git/v5 >=0 =0 <=6.0.0-alpha.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Several denial-of-service issues were identified in go-git when parsing maliciously crafted Git repository data. An attacker may craft a malicious .pack, .idx or loose objects that causes an application using an affected version of go-git to panic or consume excessive resources. This can lead to denial of service in applications that use go-git to clone, fetch, open, or otherwise process untrusted repositories or Git object data. Exploitation requires the ability to alter read-only files such as .pack or .idx from the local repository's .git/objects/pack/ directory. Alternatively, the user would need to be interacting with a malicious remote server, which is not recommended and exposes users to a broader class of security risks beyond this issue. Patches Users should upgrade to a patched version in order to mitigate this vulnerability. Versions prior to v5 are likely to be affected, users are recommended to upgrade to a supported go-git version. Credits go-git thanks…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w5pp-99ch-qj29
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-w5pp-99ch-qj29 Advisory: go-git: Malformed Git object data may cause panics or resource exhaustion IDs: GHSA-w5pp-99ch-qj29 Record: https://patchnext.com/advisories/ghsa-w5pp-99ch-qj29 (revision 1, source checked 26 Oct 2026, 15:23 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/go-git/go-git/v6 6.0.0-alpha.4; github.com/go-git/go-git/v5 5.19.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/go-git/go-git/v6: affected <= 6.0.0-alpha.3; fixed in 6.0.0-alpha.4 - Go github.com/go-git/go-git/v5: affected <= 5.19.0; fixed in 5.19.1 ## Suggested inspection (read-only) - Go github.com/go-git/go-git/v6: check the installed version with your package manager. - Go github.com/go-git/go-git/v5: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/go-git/go-git/v6, github.com/go-git/go-git/v5. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w5pp-99ch-qj29 (GitHub-reviewed advisory GHSA-w5pp-99ch-qj29 lists affected ranges: Go github.com/go-git/go-git/v5 >=0 =0 <=6.0.0-alpha.3) Commands are suggestions: review each one before running it.
Loading voting…