Open WebUI has vulnerable dependency on starlette via fastapi
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.5.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI open-webui
- Affected
- < 0.5.8
- Fixed in
- 0.5.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w466-2wfc-8g58 lists affected ranges: PyPI open-webui >=0 <=0.3.32
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w466-2wfc-8g58 lists affected ranges: PyPI open-webui >=0 <=0.3.32
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w466-2wfc-8g58 lists affected ranges: PyPI open-webui >=0 <0.5.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w466-2wfc-8g58 lists affected ranges: PyPI open-webui >=0 <0.5.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
In version 0.3.32 of open-webui, the application uses a vulnerable version of the starlette package through its dependency on fastapi. The starlette package versions <=0.49 are susceptible to uncontrolled resource consumption, which can be exploited to cause a denial of service through memory exhaustion. This issue is addressed in fastapi version 0.115.3.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from osv record GHSA-w466-2wfc-8g58
- Revision 3 · amended ·
Amended from ghsa record GHSA-w466-2wfc-8g58
- Revision 2 · amended ·
Amended from ghsa record GHSA-w466-2wfc-8g58
- Revision 1 · created ·
Published from osv record GHSA-w466-2wfc-8g58
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-w466-2wfc-8g58 Advisory: Open WebUI has vulnerable dependency on starlette via fastapi IDs: GHSA-w466-2wfc-8g58 Record: https://patchnext.com/advisories/ghsa-w466-2wfc-8g58 (revision 4, source checked 27 Oct 2026, 06:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: open-webui 0.5.8. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI open-webui: affected < 0.5.8; fixed in 0.5.8 ## Suggested inspection (read-only) - `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on open-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w466-2wfc-8g58 (OSV record GHSA-w466-2wfc-8g58 lists affected ranges: PyPI open-webui >=0 <=0.3.32) - Verified: https://github.com/advisories/GHSA-w466-2wfc-8g58 (GitHub-reviewed advisory GHSA-w466-2wfc-8g58 lists affected ranges: PyPI open-webui >=0 <=0.3.32) - Verified: https://github.com/advisories/GHSA-w466-2wfc-8g58 (GitHub-reviewed advisory GHSA-w466-2wfc-8g58 lists affected ranges: PyPI open-webui >=0 <0.5.8) - Verified: https://osv.dev/vulnerability/GHSA-w466-2wfc-8g58 (OSV record GHSA-w466-2wfc-8g58 lists affected ranges: PyPI open-webui >=0 <0.5.8 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…