Use After Free in Context::start_auth_session
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tss-esapi 7.1.0, 6.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io tss-esapi
- Affected
- >= 7.0.0, < 7.1.0< 6.1.2
- Fixed in
- 6.1.2, 7.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w3vw-ccc5-qr8v lists affected ranges: crates.io tss-esapi >=7.0.0 =0 <6.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact This issue only applies to applications starting authorization sessions using an explicit initial nonce. When Context::startauthsession was called with a nonce argument value of Some(...), the nonce pointer passed down through FFI to EsysStartAuthSession would be a dangling pointer, left over from a defunct instance of TPM2BNONCE. This could lead to an incorrect value being used as a nonce, though whether that value is controllable is unclear (so should be assumed as possible). The error became apparent due to changes in v1.61.0 of the Rust compiler. Logs indicating a failure due to this issue (with the 1.61.0 version of the Rust toolchain) look as follows: Patches The issue has been patched in versions 6 and 7 of the tss-esapi crate. Please update to 7.1.0 or 6.1.2. Workarounds There is no workaround that achieves the same functionality. References For more information on the cause of the issue and the fix, see this PR. For more details about the TPM2StartAuthSession command…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w3vw-ccc5-qr8v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-w3vw-ccc5-qr8v Advisory: Use After Free in Context::start_auth_session IDs: GHSA-w3vw-ccc5-qr8v Record: https://patchnext.com/advisories/ghsa-w3vw-ccc5-qr8v (revision 1, source checked 26 Oct 2026, 15:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tss-esapi 7.1.0, 6.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io tss-esapi: affected >= 7.0.0, < 7.1.0; < 6.1.2; fixed in 6.1.2, 7.1.0 ## Suggested inspection (read-only) - crates.io tss-esapi: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tss-esapi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w3vw-ccc5-qr8v (GitHub-reviewed advisory GHSA-w3vw-ccc5-qr8v lists affected ranges: crates.io tss-esapi >=7.0.0 =0 <6.1.2) Commands are suggestions: review each one before running it.
Loading voting…