@grackle-ai/server has Missing WebSocket Origin Header Validation
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@grackle-ai/server 0.70.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 0.70.2
- Fixed in
- 0.70.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w3hv-x4fp-6h6j lists affected ranges: npm @grackle-ai/server >=0 <0.70.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w3hv-x4fp-6h6j lists affected ranges: npm @grackle-ai/server >=0 <=0.70.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact The WebSocket upgrade handler in the server validates authentication (API key token or session cookie) but does not check the Origin header. A malicious webpage on a different origin could initiate a WebSocket connection to ws://localhost:3000/ws if it can leverage the user's session cookie (which is SameSite=Lax, allowing top-level navigations). This enables cross-origin WebSocket hijacking — if a user visits a malicious site while a Grackle session is active, the attacker's page could open a WebSocket and subscribe to real-time events (session output, task updates, environment state). Affected code: - packages/server/src/ws-bridge.ts:80-91 — connection handler accepts WebSocket upgrades without checking req.headers.origin Patches Fix: Validate req.headers.origin against an allowlist before accepting connections: Workarounds Ensure the Grackle server is only accessible on 127.0.0.1 (the default). Do not use --allow-network in untrusted network environments. Resources -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w3hv-x4fp-6h6j
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-w3hv-x4fp-6h6j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-w3hv-x4fp-6h6j Advisory: @grackle-ai/server has Missing WebSocket Origin Header Validation IDs: GHSA-w3hv-x4fp-6h6j Record: https://patchnext.com/advisories/ghsa-w3hv-x4fp-6h6j (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @grackle-ai/server 0.70.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @grackle-ai/server: affected <= 0.70.2; fixed in 0.70.3 ## Suggested inspection (read-only) - `npm ls @grackle-ai/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @grackle-ai/server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w3hv-x4fp-6h6j (OSV record GHSA-w3hv-x4fp-6h6j lists affected ranges: npm @grackle-ai/server >=0 <0.70.3 (fixed)) - Verified: https://github.com/advisories/GHSA-w3hv-x4fp-6h6j (GitHub-reviewed advisory GHSA-w3hv-x4fp-6h6j lists affected ranges: npm @grackle-ai/server >=0 <=0.70.2) Commands are suggestions: review each one before running it.
Loading voting…