Skip to content

← Actionable
High, CVSS 8.5amended

Nx: OS command injection via git revisions and remote refs

GHSA-w2vw-w76x-qr89

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nx 23.1.1, 22.7.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm nx

    Affected
    >= 14.0.0, < 22.7.8>= 23.0.0, < 23.1.1
    Fixed in
    23.1.1, 22.7.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Nx core builds several git invocations as shell command strings with untrusted values interpolated into them, so a value that should be a git revision or ref is parsed by /bin/sh instead. Two entry points are reachable by an attacker: affected commands, where defaultBase / affected.defaultBase from nx.json (and the NXBASE / NXHEAD environment variables) reach git merge-base and git diff; and nx import, where a branch name advertised by a remote repository reaches git fetch, git checkout, and git config. In both cases an attacker who controls a repository — or who opens a pull request against one — gets arbitrary command execution on the machine of anyone who runs an ordinary Nx command against it, including CI runners. The affected path is the more serious of the two. nx affected and nx show projects --affected run constantly in CI, so a pull request that changes nothing but nx.json is enough to execute code on the runner with whatever credentials that job holds. Severity…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-w2vw-w76x-qr89

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-w2vw-w76x-qr89

  4. Revision 1 · created ·

    Published from ghsa record GHSA-w2vw-w76x-qr89

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-w2vw-w76x-qr89

Advisory: Nx: OS command injection via git revisions and remote refs
IDs: GHSA-w2vw-w76x-qr89
Record: https://patchnext.com/advisories/ghsa-w2vw-w76x-qr89 (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nx 23.1.1, 22.7.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nx: affected >= 14.0.0, < 22.7.8; >= 23.0.0, < 23.1.1; fixed in 23.1.1, 22.7.8

## Suggested inspection (read-only)
- `npm ls nx --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nx.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w2vw-w76x-qr89 (GitHub-reviewed advisory GHSA-w2vw-w76x-qr89 lists affected ranges: npm nx >=14.0.0 =23.0.0 <23.1.1)
- Verified: https://osv.dev/vulnerability/GHSA-w2vw-w76x-qr89 (OSV record GHSA-w2vw-w76x-qr89 lists affected ranges: npm nx >=14.0.0 =23.0.0 <23.1.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…