opencv-contrib-python-headless bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (opencv-contrib-python-headless 4.8.1.78), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI opencv-contrib-python-headless
- Affected
- < 4.8.1.78
- Fixed in
- 4.8.1.78
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w2pj-9cgh-mq2c lists affected ranges: PyPI opencv-contrib-python-headless >=0 <4.8.1.78 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w2pj-9cgh-mq2c lists affected ranges: PyPI opencv-contrib-python-headless >=0 <4.8.1.78
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
opencv-contrib-python-headless versions before v4.8.1.78 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863. opencv-contrib-python-headless v4.8.1.78 upgrades the bundled libwebp binary to v1.3.2.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w2pj-9cgh-mq2c
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-w2pj-9cgh-mq2c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-w2pj-9cgh-mq2c Advisory: opencv-contrib-python-headless bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863 IDs: GHSA-w2pj-9cgh-mq2c Record: https://patchnext.com/advisories/ghsa-w2pj-9cgh-mq2c (revision 3, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: opencv-contrib-python-headless 4.8.1.78. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI opencv-contrib-python-headless: affected < 4.8.1.78; fixed in 4.8.1.78 ## Suggested inspection (read-only) - `python -m pip show opencv-contrib-python-headless`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on opencv-contrib-python-headless. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w2pj-9cgh-mq2c (OSV record GHSA-w2pj-9cgh-mq2c lists affected ranges: PyPI opencv-contrib-python-headless >=0 <4.8.1.78 (fixed)) - Verified: https://github.com/advisories/GHSA-w2pj-9cgh-mq2c (GitHub-reviewed advisory GHSA-w2pj-9cgh-mq2c lists affected ranges: PyPI opencv-contrib-python-headless >=0 <4.8.1.78) Commands are suggestions: review each one before running it.
Loading voting…