Skip to content

← Actionable
Medium, CVSS 4.7amended

Flask-Security has an Open Redirect issue

GHSA-w2j7-f3c6-g8cw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask-security 5.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Open Redirect in Flask-Security Summary flasksecurity.utils.validateredirecturl() can allow an attacker-controlled redirect URL when subdomain redirects are enabled. The bypass uses a backslash inside the URL authority/host: Python's urlsplit() parses the full authority as evil.com\.whitelist.com or evil.com%5C.whitelist.com. Because the value ends with .whitelist.com, validateredirecturl() accepts it as an allowed subdomain of whitelist.com. This is similar in class to the previous Flask-Security-Too open redirect advisory CVE-2023-49438 / GHSA-672h-6x89-76m5, where crafted redirect URLs bypassed validation through browser URL normalization behavior. Affected Configuration The issue requires subdomain redirects to be enabled: Tested environment: Impact An attacker can craft a URL that passes Flask-Security's redirect validation and produces a 302 response to an attacker-controlled URL-like authority. This can be used for phishing or other attacks that rely on a trusted application…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w2j7-f3c6-g8cw

  2. Revision 1 · created ·

    Published from osv record GHSA-w2j7-f3c6-g8cw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-w2j7-f3c6-g8cw

Advisory: Flask-Security has an Open Redirect issue
IDs: GHSA-w2j7-f3c6-g8cw
Record: https://patchnext.com/advisories/ghsa-w2j7-f3c6-g8cw (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flask-security 5.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI flask-security: affected <= 5.8.0; fixed in 5.8.1

## Suggested inspection (read-only)
- `python -m pip show flask-security`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flask-security.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w2j7-f3c6-g8cw (OSV record GHSA-w2j7-f3c6-g8cw lists affected ranges: PyPI flask-security >=0 <5.8.1 (fixed))
- Verified: https://github.com/advisories/GHSA-w2j7-f3c6-g8cw (GitHub-reviewed advisory GHSA-w2j7-f3c6-g8cw lists affected ranges: PyPI flask-security >=0 <=5.8.0)

Commands are suggestions: review each one before running it.

Loading voting…