mcp-handler has a tool response leak across concurrent client sessions ('Race Condition')
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-handler 1.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mcp-handler
- Affected
- < 1.1.0
- Fixed in
- 1.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w2fm-25vw-vh7f lists affected ranges: npm mcp-handler >=0 <1.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w2fm-25vw-vh7f lists affected ranges: npm mcp-handler >=0 <1.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
mcp-handler versions prior to 1.1.0 accepted @modelcontextprotocol/sdk < 1.26.0 as a peer dependency. That SDK version contains a vulnerability [CVE-2026-25536] that causes concurrent requests from different clients to share server-side state including authentication context and tool execution results when a StreamableHTTPServerTransport instance is reused across requests. Note: This is not a vulnerability in mcp-handler itself. The root cause is in the peer dependency @modelcontextprotocol/sdk. Impact A low-privileged attacker making concurrent requests to an mcp-handler endpoint can read another client's session data, including authentication information and tool execution state. This is a confidentiality breach with potential for limited integrity impact. Root Cause: CVE-2026-25536 in @modelcontextprotocol/sdk < 1.26.0. The SDK did not prevent reuse of stateless transports across client connections. Patches Upgrade to mcp-handler@1.1.0. This release raises the minimum peer…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w2fm-25vw-vh7f
- Revision 1 · created ·
Published from osv record GHSA-w2fm-25vw-vh7f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-w2fm-25vw-vh7f
Advisory: mcp-handler has a tool response leak across concurrent client sessions ('Race Condition')
IDs: GHSA-w2fm-25vw-vh7f
Record: https://patchnext.com/advisories/ghsa-w2fm-25vw-vh7f (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp-handler 1.1.0. A vendor fix does not mean a deployment is fixed.
## Affected components
- npm mcp-handler: affected < 1.1.0; fixed in 1.1.0
## Suggested inspection (read-only)
- `npm ls mcp-handler --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp-handler.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w2fm-25vw-vh7f (OSV record GHSA-w2fm-25vw-vh7f lists affected ranges: npm mcp-handler >=0 <1.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-w2fm-25vw-vh7f (GitHub-reviewed advisory GHSA-w2fm-25vw-vh7f lists affected ranges: npm mcp-handler >=0 <1.1.0)
Commands are suggestions: review each one before running it.Loading voting…