Prompty: Server-Side Template Injection to Remote Code Execution in the @prompty/core Nunjucks Renderer
CVE-2026-73299GHSA-w28w-gp39-m4p6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@prompty/core 2.0.0-beta.5, 0.1.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @prompty/core
- Affected
- <= 0.1.4>= 2.0.0-alpha.1, <= 2.0.0-beta.4
- Fixed in
- 0.1.5, 2.0.0-beta.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w28w-gp39-m4p6 lists affected ranges: npm @prompty/core >=0 =2.0.0-alpha.1 <=2.0.0-beta.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w28w-gp39-m4p6 lists affected ranges: npm @prompty/core >=0 =2.0.0-alpha.1 <2.0.0-beta.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-73299: 1.78% estimated exploitation activity in the next 30 days; percentile 78.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The TypeScript Nunjucks renderer evaluated untrusted .prompty template bodies with unrestricted JavaScript member access. An attacker-controlled template could traverse constructor and prototype properties to execute JavaScript in the host Node.js process. Affected packages - npm @prompty/core versions <= 0.1.4 - npm @prompty/core versions <= 2.0.0-beta.4 Impact Applications that render untrusted, community-supplied, cloned, or LLM-generated .prompty files with the TypeScript runtime could allow attacker-controlled code execution with the privileges of the Node.js host process. Remediation Upgrade to @prompty/core 2.0.0-beta.5 or later. The patched renderer sanitizes render inputs to own-data-only values, rejects constructor/prototype member traversal, and disallows template function calls. Ordinary interpolation, conditionals, loops, and own nested data properties remain supported. Fix details The fix is merged in PR #404 and includes regression coverage for default Nunjucks…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w28w-gp39-m4p6
- Revision 2 · amended ·
Amended from osv record GHSA-w28w-gp39-m4p6
- Revision 1 · created ·
Published from ghsa record GHSA-w28w-gp39-m4p6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73299 Advisory: Prompty: Server-Side Template Injection to Remote Code Execution in the @prompty/core Nunjucks Renderer IDs: CVE-2026-73299, GHSA-w28w-gp39-m4p6 Record: https://patchnext.com/advisories/ghsa-w28w-gp39-m4p6 (revision 3, source checked 26 Oct 2026, 12:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @prompty/core 2.0.0-beta.5, 0.1.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @prompty/core: affected <= 0.1.4; >= 2.0.0-alpha.1, <= 2.0.0-beta.4; fixed in 0.1.5, 2.0.0-beta.5 ## Suggested inspection (read-only) - `npm ls @prompty/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @prompty/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w28w-gp39-m4p6 (GitHub-reviewed advisory GHSA-w28w-gp39-m4p6 lists affected ranges: npm @prompty/core >=0 =2.0.0-alpha.1 <=2.0.0-beta.4) - Verified: https://osv.dev/vulnerability/GHSA-w28w-gp39-m4p6 (OSV record GHSA-w28w-gp39-m4p6 lists affected ranges: npm @prompty/core >=0 =2.0.0-alpha.1 <2.0.0-beta.5 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…