cg vulnerable to an Open Redirect Vulnerability on Referer Header
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cg 60.2.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI cg
- Affected
- < 60.2.12
- Fixed in
- 60.2.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w228-rfpx-fhm4 lists affected ranges: PyPI cg >=0 <60.2.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w228-rfpx-fhm4 lists affected ranges: PyPI cg >=0 <60.2.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary A vulnerability has been discovered in the handling of the referrer header in the application, which could allow an attacker to conduct open redirects. The issue arises from improper validation of the referrer header in certain conditions. By manipulating the referrer header, an attacker could potentially redirect users to malicious websites, phishing pages, or other dangerous destinations. PoC If you change the referer header, you will be redirected to that domain without verifying. https://github.com/Clinical-Genomics/cg/blob/master/cg/server/invoices/views.py#L173 Impact An attacker exploiting this vulnerability could trick users into visiting malicious websites or disclose sensitive information by redirecting them to unintended destinations. This could lead to various attacks including phishing, malware distribution, or further exploitation of other vulnerabilities.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w228-rfpx-fhm4
- Revision 1 · created ·
Published from osv record GHSA-w228-rfpx-fhm4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-w228-rfpx-fhm4 Advisory: cg vulnerable to an Open Redirect Vulnerability on Referer Header IDs: GHSA-w228-rfpx-fhm4 Record: https://patchnext.com/advisories/ghsa-w228-rfpx-fhm4 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cg 60.2.12. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI cg: affected < 60.2.12; fixed in 60.2.12 ## Suggested inspection (read-only) - `python -m pip show cg`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cg. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w228-rfpx-fhm4 (OSV record GHSA-w228-rfpx-fhm4 lists affected ranges: PyPI cg >=0 <60.2.12 (fixed)) - Verified: https://github.com/advisories/GHSA-w228-rfpx-fhm4 (GitHub-reviewed advisory GHSA-w228-rfpx-fhm4 lists affected ranges: PyPI cg >=0 <60.2.12) Commands are suggestions: review each one before running it.
Loading voting…