Build corruption when using PYO3_CONFIG_FILE environment variable
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyo3 0.23.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io pyo3
- Affected
- >= 0.23.0, < 0.23.3
- Fixed in
- 0.23.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vxcf-c7mx-pg53 lists affected ranges: crates.io pyo3 >=0.23.0 <0.23.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
In PyO3 0.23.0 the PYO3CONFIGFILE environment variable used to configure builds regressed such that changing the environment variable would no longer trigger PyO3 to reconfigure and recompile. In combination with workflows using tools such as maturin to build for multiple versions in a single build, this leads to Python wheels being compiled against the wrong Python API version. All users who distribute artefacts for multiple Python versions are encouraged to update and rebuild with PyO3 0.23.3. Affected wheels produced from PyO3 0.23.0 through 0.23.2 are highly unstable and will crash the Python interpreter in unpredictable ways.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vxcf-c7mx-pg53
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-vxcf-c7mx-pg53 Advisory: Build corruption when using `PYO3_CONFIG_FILE` environment variable IDs: GHSA-vxcf-c7mx-pg53 Record: https://patchnext.com/advisories/ghsa-vxcf-c7mx-pg53 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pyo3 0.23.3. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io pyo3: affected >= 0.23.0, < 0.23.3; fixed in 0.23.3 ## Suggested inspection (read-only) - crates.io pyo3: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pyo3. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vxcf-c7mx-pg53 (GitHub-reviewed advisory GHSA-vxcf-c7mx-pg53 lists affected ranges: crates.io pyo3 >=0.23.0 <0.23.3) Commands are suggestions: review each one before running it.
Loading voting…