Skip to content

← Actionable
Critical, CVSS 9.8amended

Paperclip: OS Command Injection via Execution Workspace cleanupCommand

CVE-2026-119713GHSA-vr7g-88fq-vhq3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@paperclipai/server 2026.416.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-119713: 0.80% estimated exploitation activity in the next 30 days; percentile 56.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

| Field | Value | |-------|-------| | Affected Software | Paperclip AI v2026.403.0 | | Affected Component | Execution Workspace lifecycle (`workspace-runtime.ts`) | | Affected Endpoint | `PATCH /api/execution-workspaces/:id` | | Deployment Modes | All — `local_trusted` (zero auth), `authenticated` (any company user) | | Platforms | Linux, macOS, Windows (with Git installed) | | Date | 2026-04-13 | ---

Executive Summary A critical OS command injection vulnerability exists in Paperclip's execution workspace lifecycle. An attacker can inject arbitrary shell commands into the `cleanupCommand` field via the `PATCH /api/execution-workspaces/:id` endpoint. When the workspace is archived, the server executes this command verbatim via `child_process.spawn(shell, ["-c", cleanupCommand])` with no input validation or sanitization. In `local_trusted` mode (the default for desktop installations), this requires zero authentication. Three independent proofs of exploitation…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record GHSA-vr7g-88fq-vhq3

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-vr7g-88fq-vhq3

  3. Revision 2 · amended ·

    Amended from osv record GHSA-vr7g-88fq-vhq3

  4. Revision 1 · created ·

    Published from ghsa record GHSA-vr7g-88fq-vhq3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-119713

Advisory: Paperclip: OS Command Injection via Execution Workspace cleanupCommand
IDs: CVE-2026-119713, GHSA-vr7g-88fq-vhq3
Record: https://patchnext.com/advisories/ghsa-vr7g-88fq-vhq3 (revision 4, source checked 31 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @paperclipai/server 2026.416.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @paperclipai/server: affected < 2026.416.0; fixed in 2026.416.0

## Suggested inspection (read-only)
- `npm ls @paperclipai/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @paperclipai/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vr7g-88fq-vhq3 (GitHub-reviewed advisory GHSA-vr7g-88fq-vhq3 lists affected ranges: npm @paperclipai/server >=0 <2026.416.0)
- Verified: https://osv.dev/vulnerability/GHSA-vr7g-88fq-vhq3 (OSV record GHSA-vr7g-88fq-vhq3 lists affected ranges: npm @paperclipai/server >=0 <2026.416.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…