Skip to content

← Actionable
Medium, CVSS 5.9amended

FastMCP MCP client wrappers construct M2M OAuth providers without issuer binding — client secret redirectable to attacker-advertised authorization server

GHSA-vqqp-x5qm-5qp4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastmcp 4.1.2; fastmcp-slim 4.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI fastmcp

    Affected
    >= 4.0.0a1, < 4.1.2
    Fixed in
    4.1.2
  • PyPI fastmcp-slim

    Affected
    >= 4.0.0a1, < 4.1.2
    Fixed in
    4.1.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Maintainer assessment and remediation This report is accepted as a FastMCP credential-binding vulnerability. Affected versions of the OAuth client credentials providers do not expose the authorization-server issuer that owns pre-registered credentials. An untrusted or compromised MCP server can therefore advertise a different authorization server and receive the client secret or a signed assertion. Signing keys themselves remain local; assertion replayability depends on the assertion source and audience policy. Affected stable versions are 4.0.0–4.1.1 of fastmcp and fastmcp-slim. The wrappers were introduced in 4.0.0a1; 3.x does not include them. The 4.1.2 fix adds issuer to ClientCredentialsOAuthProvider and PrivateKeyJWTOAuthProvider and requires MCP SDK 2.2.0. It also discards refresh credentials from reloaded tokens: without persisted authorization-server metadata, inherited refresh could otherwise transmit credentials before issuer discovery, including when a cached token was…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vqqp-x5qm-5qp4

  2. Revision 2 · amended ·

    Amended from osv record GHSA-vqqp-x5qm-5qp4

  3. Revision 1 · created ·

    Published from ghsa record GHSA-vqqp-x5qm-5qp4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-vqqp-x5qm-5qp4

Advisory: FastMCP MCP client wrappers construct M2M OAuth providers without issuer binding — client secret redirectable to attacker-advertised authorization server
IDs: GHSA-vqqp-x5qm-5qp4
Record: https://patchnext.com/advisories/ghsa-vqqp-x5qm-5qp4 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fastmcp 4.1.2; fastmcp-slim 4.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI fastmcp: affected >= 4.0.0a1, < 4.1.2; fixed in 4.1.2
- PyPI fastmcp-slim: affected >= 4.0.0a1, < 4.1.2; fixed in 4.1.2

## Suggested inspection (read-only)
- `python -m pip show fastmcp`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show fastmcp-slim`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fastmcp, fastmcp-slim.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vqqp-x5qm-5qp4 (GitHub-reviewed advisory GHSA-vqqp-x5qm-5qp4 lists affected ranges: PyPI fastmcp >=4.0.0a1 =4.0.0a1 <4.1.2)
- Verified: https://osv.dev/vulnerability/GHSA-vqqp-x5qm-5qp4 (OSV record GHSA-vqqp-x5qm-5qp4 lists affected ranges: PyPI fastmcp >=4.0.0a1 =4.0.0a1 <4.1.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…