General OpenMRS Security Advisory, January 2025: Penetration Testing Results and Patches
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openmrs.module:idgen 4.14.0; org.openmrs.module:patientflags 3.0.8; org.openmrs.module:legacyui 1.21.0; org.openmrs.module:addresshierarchy 2.19.0; org.openmrs.module:attachments 3.6.0; 1 more package under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.openmrs.module:idgen
- Affected
- < 4.14.0
- Fixed in
- 4.14.0
Maven org.openmrs.module:patientflags
- Affected
- < 3.0.8
- Fixed in
- 3.0.8
Maven org.openmrs.module:legacyui
- Affected
- < 1.21.0
- Fixed in
- 1.21.0
Maven org.openmrs.module:addresshierarchy
- Affected
- < 2.19.0
- Fixed in
- 2.19.0
Maven org.openmrs.module:attachments
- Affected
- < 3.6.0
- Fixed in
- 3.6.0
Maven org.openmrs:openmrs
- Affected
- < 2.6.11
- Fixed in
- 2.6.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vpxm-cr3r-pjp9 lists affected ranges: Maven org.openmrs:openmrs >=0 =0 =0 =0 =0 =0 <3.0.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact We recently underwent Penetration Testing of OpenMRS by a third-party company. Vulnerabilities were found, and fixes have been made and released. We've released security updates that include critical fixes, and so, we strongly recommend upgrading affected modules. This notice applies to all OpenMRS instances. The testers used the OpenMRS v3 Reference Application (O3 RefApp); however, their findings highlighted modules commonly used in older OpenMRS applications, including the O2 RefApp. Vulnerability Details - The issues uncovered included broken access control (e.g. inappropriate admin access), phishing vulnerability, and stored XSS (e.g. vulnerable passwords). - No vulnerabilities were found in the O3 frontend esm modules. - The Letter of Attestation from the penetration test is available here for your reference. - After the fixes were applied, the OpenMRS O3 RefApp met a Security Level of “Excellent, Grade A”. - The full detailed Remediation Pentest Report is available to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vpxm-cr3r-pjp9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-vpxm-cr3r-pjp9 Advisory: General OpenMRS Security Advisory, January 2025: Penetration Testing Results and Patches IDs: GHSA-vpxm-cr3r-pjp9 Record: https://patchnext.com/advisories/ghsa-vpxm-cr3r-pjp9 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.openmrs.module:idgen 4.14.0; org.openmrs.module:patientflags 3.0.8; org.openmrs.module:legacyui 1.21.0; org.openmrs.module:addresshierarchy 2.19.0; org.openmrs.module:attachments 3.6.0; org.openmrs:openmrs 2.6.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.openmrs.module:idgen: affected < 4.14.0; fixed in 4.14.0 - Maven org.openmrs.module:patientflags: affected < 3.0.8; fixed in 3.0.8 - Maven org.openmrs.module:legacyui: affected < 1.21.0; fixed in 1.21.0 - Maven org.openmrs.module:addresshierarchy: affected < 2.19.0; fixed in 2.19.0 - Maven org.openmrs.module:attachments: affected < 3.6.0; fixed in 3.6.0 - Maven org.openmrs:openmrs: affected < 2.6.11; fixed in 2.6.11 ## Suggested inspection (read-only) - Maven org.openmrs.module:idgen: check the installed version with your package manager. - Maven org.openmrs.module:patientflags: check the installed version with your package manager. - Maven org.openmrs.module:legacyui: check the installed version with your package manager. - Maven org.openmrs.module:addresshierarchy: check the installed version with your package manager. - Maven org.openmrs.module:attachments: check the installed version with your package manager. - Maven org.openmrs:openmrs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.openmrs.module:idgen, org.openmrs.module:patientflags, org.openmrs.module:legacyui, org.openmrs.module:addresshierarchy, org.openmrs.module:attachments, org.openmrs:openmrs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vpxm-cr3r-pjp9 (GitHub-reviewed advisory GHSA-vpxm-cr3r-pjp9 lists affected ranges: Maven org.openmrs:openmrs >=0 =0 =0 =0 =0 =0 <3.0.8) Commands are suggestions: review each one before running it.
Loading voting…