Skip to content

← Actionable
Medium, CVSS 6.1

SimpleSAMLphp Reflected Cross-site Scripting vulnerability

GHSA-vpr3-cw3h-prw8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (simplesamlphp/simplesamlphp 1.17.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Background SimpleSAMLphp uses metadata to determine how to interact with other SAML entities. This metadata includes what’s called endpoints, which are URLs belonging to that entity where SAML messages can be sent. These URLs are used directly by SimpleSAMLphp when a message is sent, either via an HTTP redirection or by automatically posting a form to them. Description When sending a SAML message to another entity, SimpleSAMLphp will use the URL of the appropriate endpoint to redirect the user’s browser to it, or craft a form that will be automatically posted to it, depending on the SAML binding used. The URL that’s target of the message is fetched from the stored metadata for the given entity, and that metadata is trusted as correct. However, if that metadata has been altered by a malicious party (either an attacker or a rogue administrator) to substitute the URLs of the endpoints with javascript code, SimpleSAMLphp was blindly using them without any validation, trusting the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vpr3-cw3h-prw8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-vpr3-cw3h-prw8

Advisory: SimpleSAMLphp Reflected Cross-site Scripting vulnerability
IDs: GHSA-vpr3-cw3h-prw8
Record: https://patchnext.com/advisories/ghsa-vpr3-cw3h-prw8 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: simplesamlphp/simplesamlphp 1.17.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist simplesamlphp/simplesamlphp: affected >= 1.12.0, < 1.17.3; fixed in 1.17.3

## Suggested inspection (read-only)
- Packagist simplesamlphp/simplesamlphp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on simplesamlphp/simplesamlphp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vpr3-cw3h-prw8 (GitHub-reviewed advisory GHSA-vpr3-cw3h-prw8 lists affected ranges: Packagist simplesamlphp/simplesamlphp >=1.12.0 <1.17.3)

Commands are suggestions: review each one before running it.

Loading voting…