Path Traversal in angular-http-server
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (angular-http-server 1.4.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.4.4
- Fixed in
- 1.4.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vmhw-fhj6-m3g5 lists affected ranges: npm angular-http-server >=0 <1.4.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vmhw-fhj6-m3g5 lists affected ranges: npm angular-http-server >=0 <1.4.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Versions of angular-http-server before 1.4.4 are vulnerable to path traversal. Recommendation Update to version 1.4.4 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vmhw-fhj6-m3g5
- Revision 1 · created ·
Published from osv record GHSA-vmhw-fhj6-m3g5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-vmhw-fhj6-m3g5 Advisory: Path Traversal in angular-http-server IDs: GHSA-vmhw-fhj6-m3g5 Record: https://patchnext.com/advisories/ghsa-vmhw-fhj6-m3g5 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: angular-http-server 1.4.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm angular-http-server: affected < 1.4.4; fixed in 1.4.4 ## Suggested inspection (read-only) - `npm ls angular-http-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on angular-http-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vmhw-fhj6-m3g5 (OSV record GHSA-vmhw-fhj6-m3g5 lists affected ranges: npm angular-http-server >=0 <1.4.4 (fixed)) - Verified: https://github.com/advisories/GHSA-vmhw-fhj6-m3g5 (GitHub-reviewed advisory GHSA-vmhw-fhj6-m3g5 lists affected ranges: npm angular-http-server >=0 <1.4.4) Commands are suggestions: review each one before running it.
Loading voting…